Check out Half-Life Re-imagined competition results!
Check out Skewing textures in Hammer, our newest tutorial!
Welcome, Quazzi, our newest member!

logo

Site Stuff

Reference

Maps

Community

ShoutBOX

Poll

Feeling Blue

What's your favourite shade of blue?

Azure

11

Cobalt

25

Turquoise

7

Cyan

9

Royal

5

Teal

3

Onliners

1 secs

Windawz

52 secs

Urby

3 mins

Trempler

4 mins

Shepard62700FR

9 mins

James Luke

12 mins

JeffMOD

13 mins

Dimbeak

Affiliates

A gaming and technology blog by TWHL admins Penguinboy and Ant. A music blog by TWHL users Ant and Hugh.

(Windows 8.1 x64) hl.exe suspended after

[1]

Forums > HL Engine Discussion

09 Feb 17, 23:59
By EsprimoP
avatar
Member
It works fine on Win7 both x86 and x64, installed win8 then on launch, it won't start. I check the task manager, launch it, hl.exe appears, gets the status Suspended then disappears. Learned about DEP (Data Execution Prevention), followed steps for turning DEP off for chosen apps then I added the hl launcher on the list. Restarted computer, I launch it from the game directory (hl.exe). It launches. I send it to desktop as a shortcut then change the game parameter to launch my mod. Same story, gets suspended. Learned about turning DEP completely off through a command line. Successfully turned it off. Rebooted, same story. First launch succeeds, changing mod dir, nothing.
10 Feb 17, 01:39
By Crollo
avatar
Trollo
If you can launch the game from the directory but not from a shortcut, have you tried running steam with elevated privileges?
10 Feb 17, 13:36
By EsprimoP
avatar
Member
nosteam version here, if you're not supporting it, we can close this topic, no probs, there was another I made, but there were no problems with others, I never shared nor will share the pirated content, just to make things clear.
10 Feb 17, 14:09
By Crollo
avatar
Trollo
For the sake of argument, let's say you have WON, not "nonsteam".
If it is WON, then I would think the game is simply too old to run under 8/10, as microsoft broke compatibility with a lot of old games with them. Try running sven-coop (free game) as it runs on the updated half-life engine, or try running half life in opengl. That should tell you if it's the game or your OS causing issues.
10 Feb 17, 14:16
By Stojke
avatar
= O P L - 3 =
Won and other old games based on gldsrc engine work perfectly under both Windows 8 and 10 from my experience.
Check your windows installation and other vital components (like C++ Redist. , Direct X , and other (Drivers)).
10 Feb 17, 14:35
By EsprimoP
avatar
Member
@Crollo
Cracked "Steam" version, not WON, with opengl. Not WON at all.

@Stojke
It would cease to work when I launch it after boot if It's the components, so...
10 Feb 17, 15:05
By Stojke
avatar
= O P L - 3 =
It can not be guaranteed unless all is checked. Sounds to me like you are running an either outdated version of windows (old build, not updated) or are using incompatible software components, with who knows what in your system, in your steam hack-mod.
Try running the game in compatibility mode for windows Vista or other older than 8.
10 Feb 17, 15:14
By EsprimoP
avatar
Member
Okay, so the hl.exe from the game dir which leads me to the original half life (valve dir). Tried every compatibility mod, on Vista Service Pack 2, it started, loaded a map, no problems. I closed it, run it again, same problem.
10 Feb 17, 16:36
By EsprimoP
avatar
Member
It just acts as DEP is on.
10 Feb 17, 17:32
By Stojke
avatar
= O P L - 3 =
It has nothing to do with DEP, something is corrupt or misconfigured in your setup as whole.

Check all the dependencies again (DirectX, C++ Redis., etc), as upon exiting something might still be set / left running in memory as the problem fixes it self upon restarting.
11 Feb 17, 10:07
By Bruce
avatar
Member
u should understand that many cracked games contain malicious code, so this johnny dep might be trying to fight it offf
11 Feb 17, 12:22
By Archie
avatar
My Empire of Dirt
It's the price of a sandwich. Just buy it.
11 Feb 17, 12:33
By EsprimoP
avatar
Member
I guess the only solution to this problem would be running the app in a virtual machine. I did think of this before, just wanted to solve this without it anyway, but there even might be a way, but hard :^)
11 Feb 17, 22:12
By Archie
avatar
My Empire of Dirt
Quote:
I guess the only solution to this problem would be running the app in a virtual machine.


Solution
12 Feb 17, 01:05
By EsprimoP
avatar
Member
Already solved with this method smile - :)
16 Feb 17, 18:28
By Urby
avatar
Entirely brush based
I like Archie's method better.
16 Feb 17, 18:44
By Loulimi
avatar
Member
Me too.
[1]

Forums > HL Engine Discussion

Login to Reply

You must be logged in to reply.