Check out Half-Life Re-imagined competition results!
Check out Skewing textures in Hammer, our newest tutorial!
Welcome, akn, our newest member!

logo

Site Stuff

Reference

Maps

Community

ShoutBOX

Poll

Feeling Blue

What's your favourite shade of blue?

Azure

15

Cobalt

32

Turquoise

10

Cyan

11

Royal

9

Teal

3

Onliners

1 mins

Solokiller

19 mins

Jessie

26 mins

Windawz

26 mins

Penguinboy

35 mins

Shepard62700FR

2 hours

fighter667

2 hours

Ghost129er

Affiliates

A gaming and technology blog by TWHL admins Penguinboy and Ant. A music blog by TWHL users Ant and Hugh.

HL content in CS

[1]

Forums > HL Engine Discussion

14 Nov 17, 23:54
By MistaX88
avatar
Member
For a while I would create maps with only my own custom content and vanilla CS content. But recently I started wondering why I don't use some HL stuff. Despite being sold separately on Steam all of the HL content is still installed and the CS install is still set up like a mod. Just to be sure I wouldn't run into issues though, I even had a friend who owned CS 1.6 but not HL1 run a test map to make sure all was good, and it was.

So, with my latest map, I utilized a scientist and barney model as well as a few different sounds and textures. I submitted it to be added to my clan's server but the admin listed out all of the HL sounds and said he needed them (he did not, however, list the models).

Is this typically a problem with servers? There are plenty of other custom maps that utilize HL1 sounds and they're not copied over into my cstrike folder (unless they also renamed them). Is there a reason why a client would have no issue running the map while a server would?
15 Nov 17, 06:50
By potatis_invalid
avatar
Member
Did you supply a .res file? Maybe he's generating .res files using a program like ResGen and it included those sound files for some reason and he's reacting to that.

Check your file paths. Are they relative, like this:
ambience/drips.wav
Or absolute, like this:
D:/Games/Steam Games/steamapps/common/Half-Life/valve/soun
d/ambience/drips.wav

They should be relative.

Perhaps you can try specifying that the files are in the valve folder, like this: ../../valve/sound/ambience/drips.wav

I'm just speculating here. Ask the admin what the problem is and if he got an error message.
15 Nov 17, 08:42
By Solokiller
avatar
Member
The engine will always allow access to Half-Life content when running any other mod, you won't need the files in the cstrike directory.
You should ask him why he's asking for the files, it would help if we knew that.
15 Nov 17, 09:15
By potatis_invalid
avatar
Member
Also make sure all the file paths are lower-case. Windows is case-insensitive but Linux isn't and a lot of people run HL/CS servers on Linux.
16 Nov 17, 00:50
By MistaX88
avatar
Member
I've talked with the admin. He didn't get into details about when the list of sounds popped up (whether he was using resgen or tried to run the map on the server). I included a .res file so he shouldn't have had to use resgen (and the paths in the res file are relative). According to him the server doesn't have all of the Half-Life content. I don't know why. I don't run the server or have access to any administration functions beyond basic admin powers via plugins in game so I can't look at it myself. I also would wonder, if that were true, why bits and pieces of HL content are on the server, since there are other maps utilizing content from HL that do work.

I also used a couple HL models in my map, so if he did get this list of sounds from the res file it created, it should have also picked up on the models, but he only asked for the sounds.

I do know that our server is Linux based but I'm already mindful of that and use lower case for everything.
16 Nov 17, 02:02
By potatis_invalid
avatar
Member
It's really weird that it doesn't have all the Half-Life content, it really should unless they've deleted the files intentionally.
16 Nov 17, 03:38
By MistaX88
avatar
Member
Yeah, I wonder if he's not telling me something and he actually does think that everything is supposed to be in the cstrike folder. I did specifically mention that those sounds were in valve/sound/etc... and not cstrike/sound/etc...

Perhaps he just doesn't trust my manually created .res file and used resgen and now he doesn't want to tell me he used resgen. haha
17 Nov 17, 04:13
By MistaX88
avatar
Member
Alright, so I got all the information from him. He DID in fact use Resgen (even though I provided a res file) and all those sounds popped up. He still didn't seem to understand when I was telling him it was a false positive and the files were in the valve folder instead of cstrike; and that clients would not need to download them. I think he uploaded all the files superfluously to the cstrike folder on the server but in the end it doesn't matter. It didn't redownload all the files into my cstrike folder when we fired up the map on the server so all is good.
[1]

Forums > HL Engine Discussion

Login to Reply

You must be logged in to reply.