Check out Half-Life Re-imagined competition results!
Check out Skewing textures in Hammer, our newest tutorial!
Welcome, Yu2673, our newest member!


Site Stuff






Feeling Blue

What's your favourite shade of blue?














2 mins


5 mins


6 mins


12 mins


25 mins


33 mins

Dr. Orange

47 mins



A gaming and technology blog by TWHL admins Penguinboy and Ant. A music blog by TWHL users Ant and Hugh.

Train Problems

Map Vault > Problem Maps

map screenshot

Ratings Disabled

[More Screenshots]


By srry (See more)
7th March, 2006

145.2KB - RMF, BSP

Last edited: 18th November, 2007


No matter what I try, this train simply won't move at all. I've got to be overlooking something simple, because this is the first time I've used a func_track_train.

I have a trigger_auto that's supposed to start the train up when the map loads, but the train just makes that grinding noise, and doesn't move.


avatar rowleybob says: 7th March 2006, 08:14 AM
No time to look at it atm, but try checking this:

Path corners are for func_trains

Path tracks are for func track trains.

That's the only thing that ever caused a train not to move for me.
avatar srry says: 7th March 2006, 16:50 PM
Yeah, it's a func_track_train moving on path_tracks. That's all set up correctly.
avatar Habboi says: 7th March 2006, 17:13 PM
And you have a trigger_once targetting it...Erm I have an idea:

I had problems also however the train in that map moves and it has the .RMF.
avatar srry says: 7th March 2006, 17:29 PM
I think the trigger_once was left over from past experiments.
avatar srry says: 7th March 2006, 17:45 PM
Erm, I actually checked and I didn't have a trigger_once... And I'm not really sure how that other map really helps. It's a func_train, mine is a func_tracktrain.
avatar srry says: 7th March 2006, 18:37 PM
Somehow, by copying the properties off of the official HL intro maps, I got it to move. But now it just gets stuck when it reaches the path_track right before the corner. *sigh...*
avatar rowleybob says: 7th March 2006, 19:42 PM
ZombieLoffe has a tracktrain map:

And apparently so do I, lol:

I remeber them being a bit buggy/pain in the ass, but people use them all the time, so....

I haven't used one in a long time myself....
avatar srry says: 7th March 2006, 21:50 PM
I know, I've taken a look at all of those things, but I still can't figure out what's wrong. The only thing that's different about mine is that you can't control it and it's pitch is locked.
avatar rowleybob says: 7th March 2006, 22:35 PM
Try this one:

I couldn't find anything wrong with your paths/train, so the problem must lie someplace else. I tried compiling your map, but it kept crashing my HL!!!

After 4 or 5 times I gave up trying to compile it--couldn't find anything wrong with the map either...--, I dug up this old map.

Hope it helps!
avatar srry says: 7th March 2006, 23:40 PM
Thanks for all the help, guys. I got the train to work, but I still have no idea what was causing the problem.

I eventually turned the train into world brushes, and then turned them back into a func_tracktrain again, but this time, intead of copying the properties from the HL1 intro, I just set them all manually.

I have no idea how that did anything, but at least it works now!
avatar Habboi says: 11th March 2006, 10:05 AM
Weird stuff like that happens...I had a swinging rope that I copied from an old map which just went crazy during gameplay...

So I made it from scratch with same names and it worked :
avatar srry says: 13th March 2006, 02:02 AM
By the way, anybody can rip off my train as much as they want. Some credit would be really nice, but there's no way to inforce it...
avatar dragons says: 14th March 2006, 17:28 PM
Yeah there is no way to enforce it, but what I do is make a big mean and scary legal looking message in my readme ^_^
avatar altv says: 29th May 2006, 12:20 PM
Well it's a good map better than mine (new1) but I am a begginer. BUT I know something that nobody knows, I know how to use something else spimpler than multisources and multi_managers
avatar wheel says: 5th June 2006, 06:46 AM
yay... Thanx srry :D
I really wanted that train... =]
You must be logged in to comment.