Hammer has gone apeshit. Created 14 years ago2008-05-25 21:21:05 UTC by Tosse Tosse

Created 14 years ago2008-05-25 21:21:05 UTC by Tosse Tosse

Posted 14 years ago2008-05-25 21:21:05 UTC Post #250482
I have some serious issues with Hammer. I am now going to explain what's wrong, hope that atleast one of you guys have had a similar problem and know what's wrong plus how to fix it.

When using sertain entitys, namely the "cycler" and the "func_convoyer", Hammer wont let me use all the opions related to that entity. The "pitch yaw roll" option has completly disappeard from the func_convoyer and the "model" field on the cycler is also missing.

Sometimes when I am selecting a tool, Hammer randomly switch it to another.
I click on the 'block' tool and the arrow get selected, I click again and now it's the camera.

And when a map is compiled or Hammer is closed all the entitys in the maps get's unassigned and reset. If I have a group of blocks made into one "func_wall" for example, they will be seperate blocks and the "func_wall" entity wont be assigned to anything.

This is a major pain, right up the asshole.

So, anybody?
Posted 14 years ago2008-05-25 21:31:05 UTC Post #250483
Reinstalled it?
Strider StriderTuned to a dead channel.
Posted 14 years ago2008-05-25 22:29:44 UTC Post #250484
:D Yeah. I think you better reinstall it. As some viruses can enter the Hammer's directory.
Posted 14 years ago2008-05-25 23:37:42 UTC Post #250492
For the group assignment thing... Was the ignore box checked when you created the group? because sometimes it un-creates the group after you turn ignore back off.

It's weird, but you're other problems i just don't know man, sorry.
And use the compilator :)
Tetsu0 Tetsu0Positive Chaos
Posted 14 years ago2008-05-26 13:27:51 UTC Post #250530
Make sure you are using latest version of Hammer (3.5 BETA), along with the latest fgd.
Posted 14 years ago2008-05-26 14:14:49 UTC Post #250533
This infection seems to be spreading... Objects that used to work, like benches in maps and thing of that nature is now starting to dissapear when the map is played. I also get some error messages that I have not seen before,
it says something about the 'aaatrigger' texture being to large or something like that, the thing is that the 'aaatrigger' texture is not even used in this map.

I also get the a leak every other compile, without changing anything. It's no error in the map, of that Im sure, I always pay great attention to the regular walls and entitys when I map so that I don't have to hunt down leaks. I know it's not a real leak because i just get the error messages every other compile.

I frist compiled the map, worked fine (exept for the missing stuff). And then I added a few thins, namely a wooden pannel, compiled it again and I got the leak, I searched for the leak, couldn't find it and then I compiled again without changing a thing, no error. Tried again just for the heck of it, leak.

Genious@ No, it's not a viral issue, I run daily virus searches on this computer, it's a PC with Windows XP so I don't trust it.

Tets@ I doubt it, I never touch the ignore button! :P

This is some seriously fucked shit.
Posted 14 years ago2008-05-26 22:44:22 UTC Post #250562
What a strange problem.

You probably should install a fresh version of hammer and the compile tools.
Posted 14 years ago2008-05-27 01:44:36 UTC Post #250566
Hammer works perfectly fine, the problem is you.
Posted 14 years ago2008-05-27 06:33:23 UTC Post #250569
If reinstallng hammer doesn't work...re-format your computer. Because also me had and error not similar to yours and re-formated my computer because I had 50 JS/Psyme viruses. then I opened hammer again and it's all fine. It even has its own new program smell. :P
Posted 14 years ago2008-05-27 13:20:49 UTC Post #250587
This could be an FDG related problem. Jumping straight to re-formatting is dumb, plus i'm sure he doesn't care that much.

Find the most updated & recent HL FDG file and use it in place of the default, if that's what you're using.

(I would find you a link, but I'm on a school computer and the site's blocked)

Ill get you one when I get home if you've not found it.
TheGrimReafer TheGrimReaferADMININATOR
Posted 14 years ago2008-05-27 13:31:09 UTC Post #250590
There is nothing wrong with the default FDG.
Posted 14 years ago2008-05-27 15:16:48 UTC Post #250593
Actually, its better to use a FGD that is specially made for a specific version of Hammer.

Here's the latest FGD that works with Hammer 3.4/5: http://www.themightyatom.nl/hldownloads/Half-Life_fgd.zip

This one has sprite and model support (you can actually see sprites and models in Hammer).
The Mad Carrot The Mad CarrotMad Carrot
Posted 14 years ago2008-05-27 15:43:31 UTC Post #250594
Yes it is better, but there is no way the default FDG is what's causing the problems.
Posted 14 years ago2008-05-27 15:59:58 UTC Post #250596
I think you're right, fellows. I have several different settings with seperate FGD's in hammer, for different mods. It doesn't lke the BB FGD and it does not like the CS FGD, but I had no problems what so ever with the new latest FGD for HL.

The toolchanging issue is still there though, but I think that might be caused by various drivers not wanting to work together. I noticed that when I have a mouse plugged in, it doesn?t happen, but when Im using my touchpad it does.

I reckon that the BB FGD can be fixed if I just import the BB entitys to the latest HL fgd, Im not sure if that's possible, but it should be?

When I downloaded the FGD from brainbreads website, it was just a regular .txt file and I just opend it and save it as an FGD and it worked.
Posted 14 years ago2008-05-27 20:20:55 UTC Post #250610
Some parts of Hammer do have conflicting issues with Vista but i found it worked fine on XP. I agree that a reinstall is needed. I always have a problem when I want to change texture sets. I remove old wads, restart hammer, add new wads and then it crashes and doesn't start up again until I reinstall.

@Duck - come on man, that's just not helpful THIS IS A SERIOUS ISSUE :)
We need Tosse to map so he makes more cool maps!!!
Posted 14 years ago2008-05-27 21:34:59 UTC Post #250615
This is an XP computer! :) Me other one, that I do all the other stuff is the computer with Vista!

Anyway, it's just not that big of a pain now that we figured out what's wrong.
So you can probably expect a new map for brainbread any day now!

Thanks again guys.
Posted 14 years ago2008-05-28 02:15:17 UTC Post #250620
Yay, I saved you a re-format :>
TheGrimReafer TheGrimReaferADMININATOR
You must be logged in to post a response.