Hammer is unavailable Created 3 months ago2018-03-24 11:44:17 UTC by Screamernail Screamernail

Created 3 months ago2018-03-24 11:44:17 UTC by Screamernail Screamernail

Posted 3 months ago2018-03-24 11:44:17 UTC Post #339087
I admit that I did download that non-steam version of Half-Life 2, just because I like old graphics better. (Cause games aren't mean't to be realistic) I tried to play one of my own made maps but the file format where too new, so I tried setting up hammer for it and now I messed up and are now unable to work on HL2 maps.(The SDK way doesn't work either)

I need to figure out what went wrong so I can describe what happened. In the mean time I expect responses about what to do now.
Posted 3 months ago2018-03-24 12:01:14 UTC Post #339088
Use the Steam version of the game, don't use the Source SDK because that's outdated, the latest version of all tools are located in common/Half-Life 2/bin.

I would advise against mentioning the use of non-Steam tools and games because we can't support that in any way. Use official versions of games only.
Posted 3 months ago2018-03-24 12:09:51 UTC Post #339089
I can't open it. Nothing happens when I click on it.

EDIT: Never mind I made it work again. But now most of the textures are gone.
Posted 3 months ago2018-03-24 12:18:18 UTC Post #339090
Posted 3 months ago2018-03-24 12:28:44 UTC Post #339091
I thought you told me not to use the SDK. And all textures are checkerboards.
Posted 3 months ago2018-03-24 12:56:45 UTC Post #339092
That page tells you not to use the SDK, check the section "Authoring tools currently shipped as beta with their respective games".

Please read that page and check the rest of the wiki first. It will help solve your problems.
You must be logged in to post a response.