Recent micro stutter in Goldsrc? Created 1 month ago2019-06-22 06:30:18 UTC by MistaX88 MistaX88

Created 1 month ago2019-06-22 06:30:18 UTC by MistaX88 MistaX88

Posted 1 month ago2019-06-22 06:30:18 UTC Post #342774
Has anyone else been having recent micro stutter issues in Goldsource games? All night I didn't seem to be having any issues (other than some earlier server side lag spikes and stuttering that was affecting everyone). But then I started getting this crap:
User posted image
Happened both online and offline. I was worried my GPU was starting to have issues but I fired up some other games and they ran fine (HL2 well over 200fps, occasionally hitting the 300fps cap). My system is out dated by today's standards (GTX570, 3.1Ghz i5) but obviously way overkill for Goldsrc.

I've been back to playing CS the last couple weeks, but took a break this week until tonight, and was away from it for a good 6 months before that. I know there has been an update or two. I want to say Valve borked something but then again, the problem didn't show up right away, I had plenty of smooth games on maps of varying wpoly and epoly counts. The map in that screenshot typically runs smooth as glass for me just like any map normally does in this old game engine. I verified game cache, it actually re-downloaded the cs file but the problem persisted. Problem was present in Condition Zero as well and in Half-Life.
Posted 1 month ago2019-06-22 08:13:54 UTC Post #342775
GoldSrc is not a very stable engine, the same thing has been happening to me every once in a while over many years, on different versions of HL and different OSes.
Posted 1 month ago2019-06-22 16:35:34 UTC Post #342776
I've solved the problem!

It had nothing to do with hl.exe

Started poking around and noticed I was having some high cpu usage while idle. Rundll32.exe was the culprit, but not really the culprit.

Downloaded Process Explorer. That told me that Rundll32 was running gameux.dll which is Microsoft's useless Game Explorer that you can't disable.

So I disabled it. I had to look up how to give myself permission to modify a dll file in the SysWOW64 folder but once I did that, I gave myself permission to modify gameux.dll, task killed the current rundll32 task in Process Explorer, and then renamed gameux.dll. I'll have to see if Windows throws a fit next time I restart my machine, but for now, my CPU usage is down and CS is running like butter again.

Weird though that it wasn't seeming to have an affect (or at least, no noticeable affect) on newer, more resource intensive games.
Posted 1 month ago2019-06-22 17:19:06 UTC Post #342777
There have been a number of recent reports about Game Explorer interfering with Half-Life: https://github.com/ValveSoftware/halflife/issues/2543
Posted 1 month ago2019-06-22 18:41:41 UTC Post #342779
That post describes exactly what I was seeing, and killing Game Explorer fixed the stuttering. I haven't rebooted my machine yet since stopping the stuttering but when I do I'll have to check if that first launch failure still persists as well (an issue I was also having but thought it was separate from the micro stutter as that didn't start happening til a few weeks later).

Either way, hopefully changing the name of the game explorer dll will stop it from running without causing any major errors and my problem will be solved.

Edit: Just rebooted my PC. I could launch the game on the first try, but it throws a fit. Everything hangs up, it almost appears like Windows locks up, but then it returns to normal, and the game runs just fine. It also hangs up a bit first time starting a local game (it has always been slow to start a local game on the first try, but it's now longer and appears to hang for a bit). If this is the only problem I have and it still consistently starts up, I'll take it. Launching the game is smooth and normal after the first rough launch as long as the system hasn't been rebooted.

I've been so spoiled by CS running without a hitch for so long that I've forgotten the hoops that sometimes must be jumped through to run old games properly.
Posted 1 month ago2019-06-23 07:09:32 UTC Post #342780
Dust within your system RAM / graphics card Express slot, processor and chipset thermal condition, system disk drive health - check all those first. (Aida64 , HDSentinel, Casual run AdwCleaner - things can only get better)
Micro stutter means that the machine is struggling.
Stojke StojkeOPL - 3
Posted 1 month ago2019-06-23 10:37:16 UTC Post #342781
... The cause was already found, Stojke
Archie ArchieGoodbye Moonmen
Posted 1 month ago2019-06-23 10:42:15 UTC Post #342782
I thought the game was trying to access a new sound file and was waiting for the system to give permission, because it always happens to me just before some scientist starts talking, etc.
Posted 1 month ago2019-06-23 11:14:30 UTC Post #342783
The cause was already found
Still not stopping them from performing those tasks either way, it wont hurt anything.
Stojke StojkeOPL - 3
Posted 1 month ago2019-06-23 15:49:41 UTC Post #342785
Disabling game explorer also improved my hit registry in CS massively. I only started getting the stuttering the other night, but I had been back from my 6 month hiatus for a few weeks. I thought I was just extra rusty from not playing for a while I didn't realize how bad my registry was. I've heard a lot of others on my clan's server complaining about "bad registry for at least the last few weeks". I wonder if it has to do with Game Explorer even if they aren't getting those weird startup symptoms that I was getting.
Posted 1 month ago2019-06-23 18:12:09 UTC Post #342786
Fact : CS works better with PS/2 technology keyboard and mouse.
Stojke StojkeOPL - 3
Posted 1 month ago2019-06-23 18:55:40 UTC Post #342787
Although the mistery has been solved, I'm leaving this for posterity. I also encountered stuttering in GoldSrc at some point in time and it took me a bit to figure what was happening. Turns out it was because the bluetooth speaker. But maybe this is hardware dependent, this is happening on an older laptop.
Striker StrikerI seriously doubt myself
Posted 1 month ago2019-06-24 09:13:56 UTC Post #342788
Stojke, hardware causes are possible but in this case I think it's more related to software. It's even happening to me on linux HL. As for ps/2 you are probably right, afaik its easier on cpu than usb. Also the unlimited key presses at once, I really struggled with usb keyboards on hldm when sometimes I had to use like 5 keys at once.
Posted 1 month ago2019-06-24 15:47:44 UTC Post #342789
Here's some more information: https://www.gog.com/forum/general/old_games_not_launching_and_eating_100_of_the_cpu_on_windows_7/post1

Seems that Game Explorer is having issues because they shut down a server that the dll is trying to communicate with. They really should've updated it to not phone home.
You must be logged in to post a response.