Check out Half-Life Re-imagined competition results!
Check out Skewing textures in Hammer, our newest tutorial!
Welcome, novandro150, our newest member!

logo

Site Stuff

Reference

Maps

Community

ShoutBOX

Poll

Feeling Blue

What's your favourite shade of blue?

Azure

16

Cobalt

32

Turquoise

10

Cyan

11

Royal

11

Teal

3

Onliners

20 secs

Dimbeak

3 mins

ZikShadow

7 mins

Crollo

8 mins

The Mad Carrot

9 mins

Bruce

25 mins

ciba43

26 mins

Solokiller

Affiliates

A gaming and technology blog by TWHL admins Penguinboy and Ant. A music blog by TWHL users Ant and Hugh.

Modding HL2 : problems and more problems

[1]

Forums > Source Engine Discussion

14 Mar 17, 17:54
By FregZile
avatar
Member
Hi everyone, so I'm actually trying to mod HL2 SP and I'm experimenting a couple of things but I encountered a few issues. First, I'm trying to setting up a workaround to trigger events in other levels. So, I followed this tutoriel on Moddb and it worked just fine. I managed to set up the same trick on a little more complex map and it failed : So here's what I tried to do :

First map : LVL1 : You start in the middle of a alley with a 90° corridor at both end. First corridor leads to LVL_BETA through a trigger_levelchange.
In LVL_BETA you activate a button which triggers a Env_Global. You go back in LVL1 and at the other end of the alley you're passing through another trigger_levelchange leading to LVL_CHARLIE. Here, env_global should triggers a red light. The thing is, when passing through the second trigger_levelchange, HL2 crashes... I checked, no problems with the entries, the info_landmark is in exact same spot on the grid in both maps, I removed the entites logic_auto and env_global and it still doesnt work... I'm desperate as it doesn't displaying any error box. Here's the map files, if someone want to check if I did anything wrong :

http://www.dashquate.com/wp-content/uploads
/2017/03/ChangelevelIssue_Files.7z




I also have some issues with Hammer Editor. In GoldSrc, I used J.A.C.K Hammer wich is fantastic but unfortunately it's not Source Ready, so I had to use the Source SDK Hammer editor and theres a few things that doesnt seem to work, I dont know if its normal or not :

- I Can't use the arrow keys to move blocks or vertex points, it moves the viewport camera...
- I can't use Ctrl+A, it seems that you cannot use "Select All" command at all.

And some other stuff :

- I cant enable console on menu even with "-console" in launch options, even with a bind "toggleconsole" in my cfg file, and with "enable console" checked in the options...

I think that's enough for the moment... If anyone has a an idea, feel free to share it with me! thanks
14 Mar 17, 18:33
By Shepard62700FR
avatar
Member
I'm not a Source expert but viewing this from a HL1 standpoint, it should work. I let someone else with more experience deal with your problem. However I can help you on some stuff :

Quote:
- I Can't use the arrow keys to move blocks or vertex points, it moves the viewport camera...


Check Hammer's option about "keyboard nudging" or something like that.

Quote:
- I can't use Ctrl+A, it seems that you cannot use "Select All" command at all.


Are you using a different keyboard layout than QWERTY?

Quote:
- I cant enable console on menu even with "-console" in launch options, even with a bind "toggleconsole" in my cfg file, and with "enable console" checked in the options...


For an unknown reason, command-line launch options seems to be broken under Steam. The workaround is to navigate to the folder where you "hl2.exe" is located, hold SHIFT and right-click -> "Open a command prompt here" -> "hl2.exe -dev -console" -> ENTER

You can also create a Batch file with the BAT extension in the same folder as "hl2.exe" and put the following in it :

Quote:

@echo off
start hl2.exe -dev -console
14 Mar 17, 19:46
By FregZile
avatar
Member
Hey, I'm using an Azerty keyboard (je suis français comme toi il me semble wink-wink - ;)), and even with ctrl+Q, it doesnt work! The "keyboard nudging" thing worked perfectly, so thanks for that, and about that console cmd, well it's a custom mod, so I think I need to launch through steam app!
14 Mar 17, 22:53
By Shepard62700FR
avatar
Member
Quote:
Hey, I'm using an Azerty keyboard (je suis français comme toi il me semble wink-wink - wink-wink - ;)), and even with ctrl+Q, it doesnt work!


Bienvenue chez TWHL ^^ This is strange because select everything always worked for me on Hammer 3.4/3.5/4 and J.A.C.K. so I can't really help you with this one.

Quote:
The "keyboard nudging" thing worked perfectly, so thanks for that


Glad to know it's fixed ^^

Quote:
and about that console cmd, well it's a custom mod, so I think I need to launch through steam app!


As long as Steam is launched and you are logged into your account, you can do whatever you want to with the command-line and Steam will react properly. In fact, this is how "Launch a game through Steam" works ^^

Assuming your mod is using Source SDK 2013 Singleplayer as a base, you would use the "hl2.exe" located here :

Steam\steamapps\common\Source SDK Base 2013 Singleplayer

And to order the Source engine to start your mod, just use the "-game" argument, you would have something like that :

hl2.exe -console -game mymod

Just replace "mymod" by your mod's folder (the one that contains the "gameinfo.txt" file)
[1]

Forums > Source Engine Discussion

Login to Reply

You must be logged in to reply.