so i was working on some hl2 mod, it isnt anything too serious as its just me sillying around and seeing what i can do with the engine, but then i had some weird issue. i tried to create a section where the player would need to put a plug in its place for the elevator button to work, but when i load the map, the plug teleports to fuckwhere under the map, and the cable starts ascending weirdly as this error gets printed out in the console
Ignoring unreasonable position (1096.000000,-4296.000000,-16392.626953) from vphysics! (entity plug_box)

im not really sure what to do to fix it, as it seems like i have done everything correctly (unless if i somehow missed a step which happens alot lol)

im not really sure what else to show so im just gonna drop screenshots that i think would help a bit

(yes i did set the physbox to be solid to world)
User posted image
User posted image
User posted image
if i need to provide more information if needed then i will gladly do so when i can

EDIT: getting rid of the physbox and making the plug model a prop_physics_override worked, yay 💗