Train Problems

Half-Life HL
Train Problems by srry
Posted 12 years ago2006-03-07 07:38:32 UTC • Problems • Half-Life
Loading...
Screenshot Thumbnail
Name
Train Problems
By
srry srry
Type
Map
Engine
Goldsource
Game
Half-Life
Category
Problems
Included
BSP, BSP
Created
12 years ago2006-03-07 07:38:32 UTC
Updated
10 years ago2007-11-18 19:21:31 UTC
Views
2569
Downloads
684
Comments
15
Download

No matter what I try, this train simply won't move at all. I've got to be overlooking something simple, because this is the first time I've used a func_track_train.

I have a trigger_auto that's supposed to start the train up when the map loads, but the train just makes that grinding noise, and doesn't move.

15 Comments

Commented 12 years ago2006-03-07 08:14:30 UTC Comment #11131
No time to look at it atm, but try checking this:

Path corners are for func_trains

Path tracks are for func track trains.

That's the only thing that ever caused a train not to move for me.
Commented 12 years ago2006-03-07 16:50:55 UTC Comment #11134
Yeah, it's a func_track_train moving on path_tracks. That's all set up correctly.
Commented 12 years ago2006-03-07 17:13:31 UTC Comment #11135
And you have a trigger_once targetting it...Erm I have an idea:

http://twhl.co.za/mapvault_map.php?id=1976

I had problems also however the train in that map moves and it has the .RMF.
Commented 12 years ago2006-03-07 17:29:43 UTC Comment #11136
I think the trigger_once was left over from past experiments.
Commented 12 years ago2006-03-07 17:45:24 UTC Comment #11137
Erm, I actually checked and I didn't have a trigger_once... And I'm not really sure how that other map really helps. It's a func_train, mine is a func_tracktrain.
Commented 12 years ago2006-03-07 18:37:30 UTC Comment #11138
Somehow, by copying the properties off of the official HL intro maps, I got it to move. But now it just gets stuck when it reaches the path_track right before the corner. sigh...
Commented 12 years ago2006-03-07 19:42:41 UTC Comment #11139
ZombieLoffe has a tracktrain map:

http://twhl.co.za/mapvault_map.php?id=927

And apparently so do I, lol:
http://twhl.co.za/mapvault_map.php?id=2606

I remeber them being a bit buggy/pain in the ass, but people use them all the time, so....

I haven't used one in a long time myself....
Commented 12 years ago2006-03-07 21:50:18 UTC Comment #11140
I know, I've taken a look at all of those things, but I still can't figure out what's wrong. The only thing that's different about mine is that you can't control it and it's pitch is locked.
Commented 12 years ago2006-03-07 22:35:57 UTC Comment #11141
Try this one:

http://twhl.co.za/mapvault_map.php?id=3753

I couldn't find anything wrong with your paths/train, so the problem must lie someplace else. I tried compiling your map, but it kept crashing my HL!!!

After 4 or 5 times I gave up trying to compile it--couldn't find anything wrong with the map either...--, I dug up this old map.

Hope it helps!
Commented 12 years ago2006-03-07 23:40:07 UTC Comment #11142
Thanks for all the help, guys. I got the train to work, but I still have no idea what was causing the problem.

I eventually turned the train into world brushes, and then turned them back into a func_tracktrain again, but this time, intead of copying the properties from the HL1 intro, I just set them all manually.

I have no idea how that did anything, but at least it works now!
Commented 12 years ago2006-03-11 10:05:56 UTC Comment #11170
Weird stuff like that happens...I had a swinging rope that I copied from an old map which just went crazy during gameplay...

So I made it from scratch with same names and it worked :
Commented 12 years ago2006-03-13 02:02:13 UTC Comment #11189
By the way, anybody can rip off my train as much as they want. Some credit would be really nice, but there's no way to inforce it...
Commented 12 years ago2006-03-14 17:28:51 UTC Comment #11223
Yeah there is no way to enforce it, but what I do is make a big mean and scary legal looking message in my readme ^_^
Commented 12 years ago2006-05-29 11:20:50 UTC Comment #12044
Well it's a good map better than mine (new1) but I am a begginer. BUT I know something that nobody knows, I know how to use something else spimpler than multisources and multi_managers
Commented 12 years ago2006-06-05 05:46:59 UTC Comment #12129
yay... Thanx srry :D
I really wanted that train... =]

You must log in to post a comment. You can login or register a new account.