Error about an unused entity. Created 1 year ago2017-06-24 04:21:24 UTC by GMK_5 GMK_5

Created 1 year ago2017-06-24 04:21:24 UTC by GMK_5 GMK_5

Posted 1 year ago2017-06-24 04:21:24 UTC Post #335712
Hi, the title says it clearly, it is about an error that showed up while i was trying to test my map and see if it works in a multiplayer server ( cs 1.6 ).
The following error showed up:

[META] ERROR: Couldn't find game entity 'info_texlights' in game DLL 'cstrike': /srv/steam/cstrike_test/cstrike/dlls/cs.so: undefined

I did not use that entity in my map. What is the cause of the error? And How to fix it ?
Posted 1 year ago2017-06-24 06:33:11 UTC Post #335714
Make sure you use a proper FGD. Maybe that's the problem.
Posted 1 year ago2017-06-24 07:39:50 UTC Post #335715
Counter-Strike thinks that info_texlights is an entity which is used in-game. info_texlights, at least I think so, is supposed to be an entity which is used only by compiling tools, and it should be removed after compiling, no?

If I remember, one could use an external tool to delete the entity from the .bsp. Windawz told me about it on one occasion. Ripent, isn't it?

In my opinion, you should put up light_surface entities which come with zhlt.fgd (which comes with VHLT).
They're basically like info_texlights, except one light_surface is for 1 specific texture on brushes.

So, if you have more than one light-emitting texture, then you should put more than one light_surface entity. Good luck. :)
Admer456 Admer456What's this? Custom title? OwO
Posted 1 year ago2017-06-24 08:05:18 UTC Post #335719
The compiler doesn't strip info_texlights entities from the map, Metamod then encounters a call to create one which fails. That's what the error means.

You can always request that the compiler be updated to remove it, provided no mods rely on it. I don't think anybody's still actively working on those tools though.

See this forum for more information: https://forums.svencoop.com/forumdisplay.php/217-Vluzacn-s-Map-Compile-Tools
Posted 1 year ago2017-06-24 20:09:04 UTC Post #335725
@Admer456 Indeed, I am using light_surface entity though. But in VHE there is no ripent tool that can remove info_textlights from the bsp. I guess that Batch compiler has it, shall i try compiling my map using Batch?
@Windawz I was using 2 FGD files : Halflife.fgd that comes with the game when downloaded, CounterStrike.fgd but now i am using 3, zhlt.fgd that you guys (in the previous thread) adviced me to use is included as well.
@SoloKiller I may not be proffessional in compiling tools and the way they work, but how can i " request that the compiler be updated to remove it" ?
Posted 1 year ago2017-06-24 20:34:52 UTC Post #335726
@GMK_5
I've never said it was in VHE, or any map editor for that matter.
If you installed VHLT, you would see this ripent.exe in the folder.

But I don't think that's the one you should use. Hmm, I think there's a compile command for either HLCSG or HLBSP which enables only modifying the entities, not the brushes. I should look more into that.

On the other end, I believe I once saw a BSP editor which can modify the BSP's entities. I wonder if that was just another fake memory generated by my brain, or it's actually real. :biggrin:
Admer456 Admer456What's this? Custom title? OwO
Posted 1 year ago2017-06-24 20:48:04 UTC Post #335728
@GMK_5: You can make a request in the forum that i linked. Assuming somebody is around to implement the request it can be done.
Posted 1 year ago2017-06-24 23:50:28 UTC Post #335730
Dude, this may be happening because of halflife.fgd.

Try removing it. I use only two fgds: a cs one and zhlt.fgd
Posted 1 year ago2017-06-25 00:38:43 UTC Post #335731
@Admer456 I have ripent.exe in my tools folder, but to run it do i just have to open it and it will do the work?
the tool you are talking about can be found here: http://gamebanana.com/tools/download/5061 I tried using it but i did not find any info_textlights in my bsp settings. For the command on CLG or BSP i have no idea about it.
@Solokiller it seems that their forums do not accept my registration, it says my e-mail is banned and I have no clue why and it is my 1st time registring there, I even tried with another e-mail.
@Windawz I will remove it and try.
Posted 1 year ago2017-06-25 14:04:45 UTC Post #335738
Nop, still didn't work and it shows the same error. Any suggestions on what to do?
Posted 1 year ago2017-06-26 04:55:02 UTC Post #335752
"and see if it works in a multiplayer server"
Have you tried to start a LAN game on your map?
You must be logged in to post a response.