Place osprey with command problem Created 5 months ago2021-02-19 05:31:25 UTC by Hardian GT Hardian GT

Created 5 months ago2021-02-19 05:31:25 UTC by Hardian GT Hardian GT

Posted 5 months ago2021-02-19 05:31:25 UTC Post #345355
I was going to spawn a path_corner and grunt,and i type "ent_create monster_osprey target path_corner" in console,the osprey where gone and only can hear sound

Sorry for my bad english

If you Don't know this problem,please watch it
https://youtu.be/GxPX7Xa7KHg
Posted 5 months ago2021-02-19 09:08:08 UTC Post #345356
Apparently the monster_osprey's origin (position) has not been set, so it's placed at the default (0, 0, 0) position. I guess Xash3D's ent_create command will place entities at the point that you're looking at, but maybe that doesn't work correctly when you're looking at the sky, I don't know.

What happens when you use the ent_last_origin command after creating the path_corner? What happens when you manually specify the positions (ent_create path_corner targetname point origin "-200 -900 -1000", and ent_create monster_osprey target point origin "-200 -900 -1000")?

If that fixes the problem, but your game crashes, then that's because the path_corner doesn't have a target. There should be no 'dead ends' in the path that the monster_osprey is following. Maybe pointing the path_corner at itself will be sufficient, but if not, then you'll need at least 2 path_corners that target each other.
Posted 5 months ago2021-03-04 09:33:09 UTC Post #345397
Okay,thanks Captain P
You must be logged in to post a response.