Shiny missing texture? Created 8 months ago2022-03-11 06:38:26 UTC by Sbni_CZ Sbni_CZ

Created 8 months ago2022-03-11 06:38:26 UTC by Sbni_CZ Sbni_CZ

Posted 8 months ago2022-03-11 06:38:26 UTC Post #346335
Hello, I have a texture problem, I wanted to find some texture on the floor and when I applied it to the brush, something like Shiny missing texture appeared there, it looks disgusting ingame.
User posted image
Posted 8 months ago2022-03-25 10:52:51 UTC Post #346361
Is there an error in the console?
Posted 8 months ago2022-03-26 21:53:59 UTC Post #346371
I've not dabbled in Source for a long time, but is this not just attempting to show a cubemap?
UrbaNebula UrbaNebulaGoldSourcerer
Posted 8 months ago2022-03-27 08:31:21 UTC Post #346372
I have no clue either but my guess would be a missing specular map
Posted 8 months ago2022-03-27 08:37:29 UTC Post #346373
i'm pretty sure that only shows up in hammer, in game it should look normal
Posted 8 months ago2022-03-27 12:10:45 UTC Post #346374
I don't recall Hammer showing cubemaps, unless you are using Hammer++
Posted 8 months ago2022-03-28 01:11:39 UTC Post #346375
Try verifying file integrity through Steam. Maybe the texture file is corrupted
Posted 6 months ago2022-05-11 09:50:50 UTC Post #346507
Make sure to place a few env_cubemap entities throughout your map, and then run the buildcubemaps command through the developer console. Building cubemaps takes a while, so it's best to only do this for final releases of your map.

Depending on the game, the map file may already have blank cubemaps in it when compiled which are not overwritten when building cubemaps, so you'll have to manually delete the cubemaps first. This can be done through a BSP pack lump editing tool such as either BSPZip or a third-party GUI tool like VIDE.
Dr. Orange Dr. OrangeSource good.
You must be logged in to post a response.