Looping sounds doesn't work (EP2) Created 2 months ago2024-03-19 22:19:55 UTC by CPripyatUit CPripyatUit

Created 2 months ago2024-03-19 22:19:55 UTC by CPripyatUit CPripyatUit

Posted 2 months ago2024-03-19 22:19:55 UTC Post #348663
I've consulted the VDC article on this (Looping a sound) and tried two of the programs there, LoopAuditioneer and Goldwave.

LoopAuditioneer lets me create loop points, for which I can input precise sample numbers, but which Source just straight up doesn't pick up on. The entire file loops. It also lets me create cue points, which I can only create by vaguely clicking into the waveform with the mouse without any sort of sample precision.

Goldwave lets me create cue points by inputting specific timecodes, so that's what I did. I used their online version, since I didn't want to bother with the trialware. I named them as the wiki shows (start_cue and end_cue) and saved the file.

The entire file just loops from start to finish as well.

My files are 44.1 kHz 16-bit PCM WAV files, which is within the specifications the VDC wiki outlines ("Source supports uncompressed 8-bit and 16-bit PCM"). I used a hex editor to verify the appropriate "cue" chunk has been written into the file by Goldwave.

I'm a little out of my depth here and at my wits' end; I've followed the tutorials letter for letter and it still doesn't work. What am I doing wrong?
Posted 2 months ago2024-03-19 22:20:56 UTC Post #348664
This is for music, btw; I've tried a different solution where I rendered intro and looping part of a song separately and played them by repeatedly triggering the PlaySound input of the ambient_generic, but even with precise timings, there was a noticable gap in there, so that didn't work either.
Posted 2 months ago2024-03-20 08:11:11 UTC Post #348665
It appears Source just ignores the ending cue point. At the end of the file, it correctly loops back to the start cue, so I suppose that's something.

No idea how to make any sort of "wind down" now though, if it's impossible to loop the middle and later play the end...
You must be logged in to post a response.