Level change only works after saving and loading Created 3 days ago2020-06-30 15:40:54 UTC by AleshaPop AleshaPop

Created 3 days ago2020-06-30 15:40:54 UTC by AleshaPop AleshaPop

Posted 3 days ago2020-06-30 15:40:54 UTC Post #344488
The problem is that when a trigger for changing a level is activated, it does not change, but if after that you save the game and load, then the level will change. Help, I don’t know what to do, the trigger and the landmark are installed correctly on both maps.
Posted 1 day ago2020-07-03 07:23:22 UTC Post #344495
That's not really a lot of information to go on, but I assume this is for GoldSource? Are you using Hammer or JACK? Also, are you running the map from the console or the compile process? Level changes can act strangely if you run the map from the editor after compiling. It's best to disable this and run the map via the console.
UrbaNebula UrbaNebulaGoldSourcerer
Posted 1 day ago2020-07-03 08:57:45 UTC Post #344496
I work in JACK, GoldSource, and run map through the console
Posted 1 day ago2020-07-03 11:36:45 UTC Post #344497
OK, so it's not the usual issue that I am aware of. Very strange. Are you able to get a simple level change working between a couple of example maps, like say, just a short corridor? Or does this only affect a specific couple of maps that you are working on?

If you can get a simple levelchange example map to work, then it might be an issue with the setup in the map you're working on and you might need to upload them to the problem maps vault so that we can see the setup, or post screenshots of your map grid and the entities used to changelevel.

But first things first, can you get a transition to work between two simple example maps?
UrbaNebula UrbaNebulaGoldSourcerer
Posted 1 day ago2020-07-03 11:49:31 UTC Post #344498
Generally or only between problematic maps?
Posted 1 day ago2020-07-03 11:55:26 UTC Post #344499
By the way, the map to which the transition is carried out, I changed the skybox in the map settings to Desert. Could this be a problem due to skybox? It's just that this is the only map setting that I changed.
Posted 23 hours ago2020-07-03 12:52:26 UTC Post #344500
I noticed one more interesting detail: If you start the game right away with the map where the transition is, the transition works without problems. The problem appears if you start the new game or from some previous map.
Posted 18 hours ago2020-07-03 17:35:37 UTC Post #344502
I already solved the problem, thanks and don’t worry :) .It turns out that when switching to the problem map, the player fell down and there was a transition. The fact is that I set the landmark close to the trigger and during the transition they apparently conflicted and the transitions did not work on this map anymore.
Posted 15 hours ago2020-07-03 20:51:48 UTC Post #344504
Alright, glad you got it sorted. :)
UrbaNebula UrbaNebulaGoldSourcerer
You must be logged in to post a response.