game crashes if i shoot a tracer Created 1 month ago2021-12-26 22:59:11 UTC by Drooga Drooga

Created 1 month ago2021-12-26 22:59:11 UTC by Drooga Drooga

Posted 1 month ago2021-12-26 22:59:11 UTC Post #346163
so i followed admers tutorial on how to get better view bobbing but as soon as i fire any hitscan weapon e.g. mp5 or glock the game will just freeze for a few seconds and close
unrelated: the health count just shows the electricity hazard icon at all times
Posted 1 month ago2021-12-26 23:20:05 UTC Post #346164
Did ya compile both the client DLL and the game DLL? (hl_cdll and hldll projects)
Admer456 Admer456If it ain't broken, don't fox it!
Posted 1 month ago2021-12-27 08:47:17 UTC Post #346165
i didn't compile the game dll but it still crashes with the game dll compiled
Posted 1 month ago2021-12-27 10:11:59 UTC Post #346166
Try compiling the SDK without any view bobbing changes, and make sure you're running the latest version of Half-Life on Steam, and make sure you placed the DLLs into a mod folder in the right places. Which exact steps did you take while following that tutorial?
Admer456 Admer456If it ain't broken, don't fox it!
Posted 1 month ago2021-12-27 14:04:39 UTC Post #346167
i tried to run it without any view bobbing changes but it still crashed, as for the steps i just copied it from here because it was midnight and i was kinda tired so
Posted 1 month ago2021-12-27 14:18:12 UTC Post #346169
What HL SDK did you use? I am guessing halflife-updated as a base.
Admer456 Admer456If it ain't broken, don't fox it!
Posted 1 month ago2021-12-27 14:39:16 UTC Post #346170
i use an older version of halflife-updated because the solution won't compile on vs2019 and it constantly errors on some std::atomic thingy
Posted 1 month ago2021-12-29 11:48:47 UTC Post #346171
What is the error you're getting?
Posted 1 month ago2021-12-29 12:10:52 UTC Post #346172
it doesn't do any errors it just closes
Posted 4 weeks ago2021-12-29 22:46:12 UTC Post #346173
i use an older version of halflife-updated because the solution won't compile on vs2019 and it constantly errors on some std::atomic thingy
What is the error you're getting related to std::atomic?
Posted 4 weeks ago2021-12-30 15:53:36 UTC Post #346175
You've instantiated std::atomic<T> with sizeof(T) equal to 2/4/8 and alignof(T) < sizeof(T). Before VS 2015 Update 2, this would have misbehaved at runtime. VS 2015 Update 2 was fixed to handle this correctly, but the fix inherently changes layout and breaks binary compatibility. Please define _ENABLE_ATOMIC_ALIGNMENT_FIX to acknowledge that you understand this, and that everything you're linking has been compiled with VS 2015 Update 2 (or later). hl_cdll C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\include\atomic 1462
this only happens on inputw32.cpp in cl_dll for some reason without any modifications
Posted 4 weeks ago2021-12-30 17:16:16 UTC Post #346176
This happens because of a problem in older versions of the STL included with Visual Studio. It was removed at some point: https://github.com/microsoft/STL/issues/717

Make sure you're using Visual Studio 2019 or newer with the v141 toolset or newer, make sure it's not the XP toolset and make sure Visual Studio is up-to-date. Run the Visual Studio Installer and install any updates you get for Visual Studio.

If the problem persists, let me know which version of Windows you're using and which version of Visual Studio you're using (the exact version number, like 16.11.8).
You must be logged in to post a response.