how do i replace embedded textures on bsp maps? Created 2 weeks ago2022-07-24 18:56:45 UTC by petergriffinxxxtentacion petergriffinxxxtentacion

Created 2 weeks ago2022-07-24 18:56:45 UTC by petergriffinxxxtentacion petergriffinxxxtentacion

Posted 2 weeks ago2022-07-24 18:56:45 UTC Post #346746
I know the convar "r_wadtextures 1" is an option, but my texture's dimensions are pretty big and because of that, this error comes up:
"TEX_LoadLump: texture lump "texture file name" too large to load"
So i wanted to know how i could replace embedded textures in existing bsp maps to avoid that error?
Posted 2 weeks ago2022-07-24 20:01:15 UTC Post #346747
This recently came up on Discord as well. The303 pointed out that ripent.exe (one of the programs that's included in ZHLT / VHLT) can export and import textures from/into bsp files:

ripent.exe -textureexport "C:\where\is\your\valve\maps\mapname.bsp"
This will export embedded textures to a mapname.wad file in the same directory.

ripent.exe -textureimport "C:\where\is\your\valve\maps\mapname.bsp"
This will import textures from a mapname.wad file in the same directory, overwriting the embedded textures in the specified .bsp file.

And if, for some reason, you need to remove embedded textures, you can do so with WadMaker:
wadmaker.exe -remove "C:\where\is\your\valve\maps\mapname.bsp"
Posted 2 weeks ago2022-07-24 23:44:17 UTC Post #346748
i didn't know about that method until now so thanks! i tried using ripent, but when it tries to read my .wad file it gives "File read failure", it recognizes the path and name of the wad but for some reason can't read it, tried both 32 and 64 bit versions of ripent but no luck, even with the original halflife.wad it spews this error out. here's the log below:
Command line: ripent -textureimport "C:\Users\Alex\Documents\xash port\valve\maps\c1a0.bsp"
Arguments: -textureimport "C:\Users\Alex\Documents\xash port\valve\maps\c1a0.bsp"

-= Current ripent Settings =-
Name | Setting | Default
-------------------|-----------|-------------------------
chart [ off ] [ off ]
max texture memory [ 33554432 ] [ 33554432 ]
max lighting memory [ 50331648 ] [ 50331648 ]

mode [ N/A ] [ N/A ]
parse [ off ] [ off ]
texture mode [ Import ] [ N/A ]
texture parse [ off ] [ off ]
write extent file [ off ] [ off ]
delete rad textures [ off ] [ off ]

Reading C:\Users\Alex\Documents\xash port\valve\maps\c1a0.wad.
Error: File read failure

----- END ripent -----
Posted 2 weeks ago2022-07-25 21:47:29 UTC Post #346752
Can you open C:\Users\Alex\Documents\xash port\valve\maps\c1a0.wad with Wally or HL Texture Tools to verify that it's a 'good' wad file?
You must be logged in to post a response.