How to Exactly Compile Models for WON Versions and possible .max-.smd Conversions? Created 4 months ago2024-03-14 06:30:46 UTC by Nswthomasfan Nswthomasfan

Created 4 months ago2024-03-14 06:30:46 UTC by Nswthomasfan Nswthomasfan

Posted 4 months ago2024-03-14 06:30:46 UTC Post #348647
Hi there,

I have multiple Questions regarding Half-Life Modding from having been reading multiple Threads regarding making Mods for it, But I'm start with 2 Modelling Related Questions.

So for No.1 - I wonder how does one exactly Models for the Pre Steam Versions of Half-Life (Aka The WON Versions)? I'm asking as I'm working on a mod for it (I'm using Version that was released in Late 1999 as the Game of the Year Edition which has this Cover Art - even though Most Modern Day WON-Based mods seem to target the Last Version [V1.1.1.0]) That recreates how Half-Life looked when It was shown at the 1998 E3 Convention but I'm having a Problem when trying to Compile models for it.

As an Example, I'm trying to Compile the early MP5 model (forcedperspective.smd) that's in the SDK with the Textures from the 0.52 Alpha Model (But using the righthandtop/lefthandtop and right_thumb textures in the SDK that are dated 11/06/1997 to 01/07/1998 [According to the Mini SDK's file Dates whereas the Standard/Full Versions overwrite the date]), but when I try to Compile it, The Command Prompt says the .smd dosen't Exist. I tried the studiomdl.exe from both the Mini SDK (From November 25th 1998 only a few days after the Game's Release) and the Final Version (From October 2002 before the SDK was added to Steam around August 2013) and the same Error occurs Regardless of Which Compiler I attempt to use.

No.2 - Another Problem I have is that It's been known in recent Years since around 2016 that one can find Early Versions of some of the Models hidden within the .max Files in 3Ds Max (Here's where the Defunct Thread where I discovered it. - ). This has gotten me interested in wanting to use them for the Mod I'm working on But I'm unable to open the .max Files. I've tried installing 3Ds Max 4 (Which I founded here - via ) but the Program wouldn't work (And I later read that Older Versions of 3ds Max are not Compatible with Newer Windows Versions) So recently I tried installing both a Windows XP 32 bit Virtual Machine as well a Version of 3Ds Max from 2009 that I founded with a Crack but those didn't work either.

So I wonder How exactly do i get Models to Compile in the Mod Directory or if anyone has the .max Files converted to .smd? (Given how most of the .smd files in the SDK that aren't "template_biped" or "_reference" only contain the Animation Skeletons) If So, Would Anyone also have a List of which textures that aren't in the SDK But are mentioned as Missing Files for Specific Models in 3Ds Max.

I aplogise for making what could be a Long First Post, But Any Help for these 2 Model related Questions (in terms of compiling as well as Early Meshes in .max Files) I have would be appreciated.

  • NSWThomasFan.
Posted 4 months ago2024-03-14 07:21:46 UTC Post #348648
I once compiled a model this way. Consider a directory structure like below. I probably had similar problems to the ones you describe.

studiomdl.exe (forgot which version, 173.056 bytes, date 1998.10.20)

Contents of box.qc:

$modelname mdl/box.mdl
$cd smd
$cdtexture bmp

$body studio "box"

$scale 1.0
$origin 0 0 0

As for the original .max files, I could open it in 3D Studio Max 1.2 on Windows 98SE in QEMU. Read the documents in the old Half-Life SDKs.
Posted 4 months ago2024-03-14 10:54:02 UTC Post #348649
Alright Then Bruce, I also previously considered buying an Actual Windows 98 Desktop (Which would require needing to copy both the SDK and 3Ds Max over via a USB Stick) but preheaps I'll instead look into QEMU for Installing 3Ds Max 1.2 for opening the .Max Files.

As for the Compile Method, I'll try your Method for compiling Models. I wonder should the Directory Structure be in a modelsrc Directory or if it should be put directly into the Models Directory.

Anyways, I'll let you know if your method will work for me. - NSWThomasFan.

UPDATE: So as a test before attempting to Try compiling the MP5 Again, I decided to try instead compiling the Early 1998 Python - (Which I founded in the Leaked Repository for Half-Life: Source that was leaked Last Year [The Textures for the E3 1998 Shotgun plus Early RPG [Which we Only had the untextured rpg_launcher.max/.smd in the SDK for the viewmodel along with the Completed Worldmodel] were also founded in there]) and I've tried Compiling it directly inside the Models folder (Having the "bmp", "mdl" and "smd" Structure in it) But I still have the problem of "insertname.smd doesn't exist" (In this case python_gun.smd) when trying to Compile it.

If this Helps, Here's what I've modified in python.qc incase it helps in figuring out what's preventing it from compiling.

$modelname "v_357.mdl"
$creature "models\v_python\bmp\barehanded"
$scale 1

/ / whole body

$body gun "python_gun"
$body bullets "python_bullets"
$body speedload "python_speedload"
$body hands "python_hands"

$origin Q -8 65

/ / $attachment 0 "python_master" 0 -14 6 Y -1
$attachment 0 "python_master" 0 -14 6

$sequence idle1 "python_idle1(simple)" loop fps 30 activity ACT_VM_IDLE 1
$sequence fire1 "python_fire1" fps 30 { event 5001 0 "31" } snap activity ACT_VM_PRIMARYATTACK 1
$sequence reload "python_reload" fps 36 { event 5004 72 "Weapon_357.Reload" } activity ACT_VM_RELOAD 1
$sequence holster "python_putaway" fps 30 activity ACT_VM_HOLSTER 1
$sequence draw "python_bringup" fps 30 activity ACT_VM_DRAW 1
$sequence idle2 "python_idle2(hammer)" loop fps 30 activity ACT_VM_IDLE 2
$sequence idle3 "python_idle3(beauty)" loop fps activity ACT_VM_IDLE 3
$sequence idle4 "python_idle4(startled)" loop fps activity ACT_VM_IDLE 4
Posted 4 months ago2024-03-15 06:35:25 UTC Post #348652
I know almost nothing about modeling, wait until someone knowledgeable helps you. My directory structure was inside a random named folder in a random location. I can just drag box.qc over studiomdl.exe or use cmd.exe to change into that folder and enter studiomdl.exe box.qc

I must warn that running Windows 98SE in QEMU is very problematic. It would be easier to buy an old PC, and you don't really need something from the 90s, any clunker from early 2000s should run Windows 98 and have drivers for it. Although plain 3D Studio Max 1.2 is missing a lot of features which are present in later 3D Studio Max versions. Valve used lots of plugins for 1.2 to get all those features, and you would have to dig through ancient warez archives to find those plugins. Read through the documents within all the SDK releases of Half-Life, they contain much information.
Posted 3 months ago2024-03-23 09:41:53 UTC Post #348668
23/03/2024 UPDATE: Alright, So i decided to try another go at using Virtualbox 5 (The Last Version to support Windows 7) for Installing an Old Version of 3Ds Max but instead of Windows XP 32 Bit I opted to use Windows 98 so I set it up, Mounted Windows 98 but after i set up, I founded one can't use Virtualbox's Guest Additions in it so I decided to Try Windows NT 4.0. This Time Virtualbox seems to be working alright and afterward I tried installing this version of 3ds Max (I hope it's okay to link stuff like this) - But I had issues with the Instructions so I uninstalled it then tried 3DsMax 2.5 using the Instructions by fgv112 listed here. - This Time it nearly went Alright but I got "Hardware lock drivers are not installed: Application will terminate" when Attempting to Launch it, Then i founded i had to install the Sentinel Driver so I installed it But I still got the same Problem regardless.

As for compiling Models, I remember once managing to compile the Early Gravity Gun for the HL2 Leak and it managed to compile but It replaced the Gravity Gun in the Leak so I had to move it into another Folder and return to the 100 .rar Parts for the Leak to Re-add the Leak's Default Gravity Gun so I wonder Would anything have to be compiled within the "valve" Directory instead of the other mod Directories for HL1 Related Stuff?
Posted 3 months ago2024-03-28 13:50:15 UTC Post #348671 works fine for me in Win 98 SE virtual machine (Virtualbox 5 and Microsoft Virtual PC 2009).
In Win 98 first install SENTINEL/WIN_95/SENTW95.EXE, then install the 3D S Max with keys, and then apply CRACK/3DSCRACK.COM to the main installed dir and run it, inside it press space.
Other possible reason for not working is maybe what you used: Windows NT 4.0...
Getting a D3D or OpenGL accel. in Virtualbox 5 or Microsoft Virtual PC 2009 for Win 98 however is a long talk... Very long...
Posted 3 months ago2024-03-28 21:20:44 UTC Post #348672
Even better - here is ver 1.1 (hybrid) running perfectly in Virtualbox 5 on Win XP SP3 x86 :
Posted 3 months ago2024-03-29 06:51:04 UTC Post #348674
Oh okay, I still have my Windows 98SE Virtual Machine on my Laptop, I used NT 4.0 as I'm unable to use the Guest Additions Add-On on Windows 98 (That I hope would allow me to Drag the SDK inside the Virtual Machine) but even though i did install it, i still couldn't drag the SDK inside the Virtual Machine (Even though I had bidirectional enabled [Which I read's meant to allow one to Drag between the Host and Guest Machine)

As for the 3Ds Max software itself, I didn't know I had to install the Sentinel Drivers BEFORE 3ds Max, The .nfo said to install them afterward but your suggestion implies the .NFO file is Wrong when it comes to setting up the Program so I'll have to Start Over, I wonder what Keys do i use?

I also never knew I had to press the space button as the .nfo Instructions made no mention it of using it for the crack but I'll try that when I go try to set it up Again.

As for Compiling models, I'm still unable to Compile models as are, but while I was fiddling with the Development Drive for Cobalt-57's Absolute Zero Mod - I accidentally ran a .batch file that Recompiled their Recreation of the E3 1998 MP5 so I ended up copying that plus the E3 Pistol (Although I didn't recompile that along with the Ted Barney and E3 Scientist Recreations which I just copied the Pre Compiled Models) into my Own Mod's Directory intill I can figure out how to Compile my own Models for it.
Posted 3 months ago2024-03-29 13:45:54 UTC Post #348675
A general note : You should use these old programs only to convert/export the old model source files to a new suitable format for use/edit with modern 3D editing software and compilers.
I have ... and :
3D Studio Max 1.2 was able to run only in XP for now
3D Studio Max 2.5 was able to run only in 98 for now
3D Studio Max 4 was able to run only in 98 for now
3D Studio Max 9 was able to run only in XP for now
Putting files inside and out of Win 98 virtual machine can be tricky, but it's doable. For easy file transfer in and out of the VM you can use ver.1.2 as you can see from above, as it's mega easy to transfer files to a XP VM ,cos Guest Additions Add-On WILL work. I can help you to install v1.2. Just use shared folder on host as a network share in the guest, it will work all the times compared to drag and drop.
I wonder what Keys do i use?
The one from the .NFO.
Pressing space or enter INSIDE the crack dos program before closing is MANDATORY.
I'm familiar only with working with "modern" models, can't help you with compiling the 0.52 Alpha models.
Posted 3 months ago2024-03-31 15:22:04 UTC Post #348683
UPDATE NO:2 So I've just settled up a Windows XP 32bit Virtual Machine using a 2001 Iso that i'll try to install 3Ds Max v1.2 on, Would the Sentinel Drivers still need to be installed first or are those only necessary on Windows 98?.
Posted 3 months ago2024-04-01 05:44:50 UTC Post #348684
Use this :
Would the Sentinel Drivers still need to be installed first or are those only necessary on Windows 98?
I will post install instructions later, as this install is more tricky.
Posted 3 months ago2024-04-01 18:28:31 UTC Post #348685
First, some copied info from the .nfo file from the above link .iso :
This package is an "hybrid install", witch means that I used a modified install procedure from ET's CD-ROM Ver.1.0, put the 1.2 engines from WarezArt in it and completed it with Maps & Textures from ET's CD-ROM Ver.1.1.
That's why my version shows 1.1 in the screenshot, but who knows what version is this "hybrid" : 1.0, 1.1, 1.2...

There are many cracks and updates in the .iso with no clear instructions what to do (complete mess), so after some tries and errors, I find myself this to be working :
1. Install from CD:\SETUP.EXE.
2. During the install procedure, select the "Custom" type of setup.
3. Uncheck the "Tutorials" and the "Rainbow Sentinel Lock Driver".
4. Copy CD:\UPDATE\MAXCRK1\3DSMAX.EXE to the main install dir and overwrite.
5. Right click 3DSMAX.EXE and set compatibility mode to Windows 98/ME.
6. When you run the program you will still get the error (you can close the error), but the application doesn't terminate.
7. Have fun :)
Posted 3 months ago2024-04-05 01:53:15 UTC Post #348687
Alright Then, I'll try that for opening the HL SDK .max Files. Will let the users here know when I've gotten it set up later Today.
Posted 2 months ago2024-04-25 11:25:02 UTC Post #348746
25/04/2024 UPDATE: (Was meant to have been done 2 weeks ago as mentioned but other things happened) So i've done the above steps - but i couldn't launch 3ds Max 1.2 inside the WinXP SP2 Virtual Machine due to Low Memory.

But in the meantime, i eventually founded a Link for Versions 7-9 of 3Ds Max via a Reddit Post - and i had chose to use Version 8 which i've been using for 27 Days (Currently have 3 Days Remaining) but i've Managed to Converted some of the .max files to Reference .SMDs (Including a Couple of files from the recent Half Life Max File Leak - such as the scientist_template_pose1.max and different Barney Models plus the Zombie files and cinematics that show geometry for Early Versions of Specific Levels [but have not done the Female Scientist as the model lacks textures but i could export it Just incase) and have toyed around with some of the .max files and removed the Last 21 modifier's stacks from mp5sd.max (After reading on the Valve Cut Content That the Red HEV Hand MP5 can be found in the modifier's stack - http:s// Please the Whole Wiki is down as i type this Post ) before using Cannonfodder's Max 6/7 Exporter to export it to .smd to have a More Accurate Re-creation of how the MP5 Actually looked in the E3 1998 Build (Seen in the September 1998 Issue of Gamer's Republic along with the Gruntfight Video Clip).
User posted image
NOTE: The Model seen here in XSI Mod Tool v4.2 is a seperate Export from i did with Stacks 26-27 Deleted (Stack 25 is the Oldest stack that contains the HEV Hands while stacks 1-13 seem to be what appears to be the 0.52 Alpha Model while stack 14 Redid the Hand on the Back but the other Hand's Mesh was left unchanged until Stack 25)

Anyways, i tried another Attempt using Crowbar for compiling (The Studiomdl.exe is from the Absolute Zero Developer Drive's Old Compilers Directory [There's a file saying it's the Seven Co-Op Game's version which seems to be what everyone uses]) using the Directions mentioned here: - but i still keep getting errors when i tried to compile.
User posted image
And here's the .qc file i've modified for the File (Note: The Origin is from the mp5_center.qc file from Absolute Zero's Recreation while everything else are either left unchanged or my edits for the Mod i'm doing.
User posted image
i hope The Latter 2 Screenshots can better help anyone identify a mistake i may had done to help me out in regards to the problem i'm having when trying to compile Models.
You must be logged in to post a response.