my mod's training level is screwy! Created 14 years ago2004-07-31 18:49:13 UTC by JujitsuMan JujitsuMan

Created 14 years ago2004-07-31 18:49:13 UTC by JujitsuMan JujitsuMan

Posted 14 years ago2004-07-31 18:49:13 UTC Post #47214
I'm making a mod (ndey.net/tony is my website) and I'm making a training level too, but for some reason when i click on hazard course it does the old one. I have the liblist file set so the training level is the name it has to be, but it STILL won't work... HELP PLEASE!!! :x :x :x
Posted 14 years ago2004-07-31 18:50:52 UTC Post #47216
do you have the training map in the mods map directory?
Posted 14 years ago2004-07-31 18:51:25 UTC Post #47217
if it goes to the old one it sounds like you havent made it into a full mod yet, unless you included the old hazard course.
Posted 14 years ago2004-07-31 18:52:06 UTC Post #47218
maby not all the maps are in it yet.
Posted 14 years ago2004-07-31 18:54:12 UTC Post #47220
no, i made entire new one, it's all done and everything, i've set up about 7 maps in themod itself already, but it STILL won't work! I finished the training levels and it's only letting me into the original hazard course, then when i press esc it goes back to half life instead of my mod!
Posted 14 years ago2004-07-31 18:59:17 UTC Post #47223
Things to consider:
Name you Hazard course something different, like Haz1

make sure you Liblist looks something like:

game "My Mod"
startmap "Startmap"
trainmap "Haz1"
url_info "http://www.cariad.co.za/twhl"
version "1.03b"
size ""
svonly "0"
hlversion "1110"
type "SP"
gamedll "..valvedllshl.dll"

Make sure Haz1 is in your Mod's Map file.

Have you done this?
I forgot to ask WHICH Mod are you mapping for and are you using Steam?
Posted 14 years ago2004-07-31 19:04:40 UTC Post #47226
I prefer this setup:

game "My Mod"
gamedir "your_mod_dir_here"
startmap "startmap"
trainmap "haz1"
url_info "http://www.cariad.co.za/twhl"
version "1.03b"
size ""
svonly "0"
hlversion "1110"
type "SP"
gamedll "dlls/hl.dll"
The Mad Carrot The Mad CarrotMad Carrot
Posted 14 years ago2004-07-31 19:04:55 UTC Post #47227
i'm NOT using steam, and i'm making it myself. by the way, if anyone has free time and would like to make a model for my mod, i got designs ;) . anyway, I have a different map name, it's train. but i didn't put in the url info and other stuff. who knows, could make a difference, prolly not though. any more ideas? :nuts:
Posted 14 years ago2004-07-31 19:13:50 UTC Post #47228
still nothing it just won't do it, here's what my liblist looks like:

// Valve Game Info file
// These are key/value pairs. Certain mods will use different settings.
//
game "Your First Mission"
gamedir "C:SierraHalf-Lifeyfm"
startmap "fartherin"
trainingmap "train"
url_info "http://ndey.net/tony"
version "beta"
size ""
hlversion "1110"
type "SP"
gamedll "dlls/hl.dll"

it still won't work for some reason. I put it in the map directory and everything, WHAT'S WRONG!
Posted 14 years ago2004-07-31 19:22:45 UTC Post #47233
Posted 14 years ago2004-07-31 19:24:41 UTC Post #47234
trainmap

NOT trainingmap
Posted 14 years ago2004-07-31 19:25:51 UTC Post #47236
hmm, lol, don't know why it said that. lol WHOOPS
Posted 14 years ago2004-07-31 19:39:36 UTC Post #47243
alright, your training map name is haz1... yes?

well, heres what i do to set up my mods. (the liblist.gam file:)

game "your mod name here"
startmap "your starting map"
trainmap "haz1"
url_info "http://[yoursitenamehere]"
version "your mod version"
size "how big your mod is"
svonly "0"
hlversion "the hlversion required to play the mod"
type: "in your case SinglePlayer?"
gamedll "put your own dll here, or use VALVe's: ...valvedllshl.dll
Posted 14 years ago2004-07-31 19:43:41 UTC Post #47246
lol, all that trouble and what i did wrong was i put training map instead of trainmap. lol, it works now though, thanks all :P
Posted 14 years ago2004-08-01 02:01:02 UTC Post #47295
You probably shouldn't put C:Sierra~ as your mod directory, just the mod subdirectory (just "yfm"). Probably.
Seventh-Monkey Seventh-MonkeyPretty nifty
Posted 14 years ago2004-08-01 06:47:51 UTC Post #47313
Floater: It's ..valvedllshl.dll, not ...valvedllshl.dll
Posted 14 years ago2004-08-01 16:43:30 UTC Post #47420
i had a fat font on, i thought it was three dots.
Posted 14 years ago2004-08-06 03:58:15 UTC Post #48353
. = current directory
.. = directory above
... = the one above that!

etc. Hence '...' would have looked in Half-Life instead of Half-Lifevalve.
Seventh-Monkey Seventh-MonkeyPretty nifty
You must be logged in to post a response.