[HELP] Change level error/glitch Created 3 months ago2021-01-11 14:04:42 UTC by SraleenTonda SraleenTonda

Created 3 months ago2021-01-11 14:04:42 UTC by SraleenTonda SraleenTonda

Posted 3 months ago2021-01-11 14:04:42 UTC Post #345202
Hello, I was making new map for my Half life mod and i have problem with change level

i have a glitch where i cant move and i'm stuck in the air when the level changes, Is there any way to fix it?

i have Two landmarks and one Trigger_changelevel

Landmark1 name: Ladm1

Landmark2 name: Ladm1

Change level

Name: changelvl1

New map name: SNAILLIF30

Landmark name : Ladm1

Change target : [NOTHING]

Delay before change target: 0

Posted 3 months ago2021-01-11 17:06:51 UTC Post #345203
Next time, please don't start multiple threads about the same problem (I'll remove the previous thread because this one contains more information).

Having said that, did you read my reply in your previous thread (see below)?
Do both maps contain an info_landmark with exactly the same name? And does each trigger_changelevel match an open, walkable space in the other level (relative to the landmarks)?

And just in case you haven't seen this yet: Tutorial: Changing Levels.
As that tutorial states, both maps must contain 1 info_landmark and 1 trigger_changelevel each, but it sounds like you've put both info_landmarks in the same level. Also, names are case-sensitive, so 'Ladm1' does not match 'ladm1'. Better stick to lowercase names everywhere, just to be safe. If you still can't get it to work after following that tutorial, consider uploading both maps to the vault so some of us can have a look at it.
Posted 3 months ago2021-01-13 06:35:58 UTC Post #345211
Hello, i a made my changelevel,
I had 2 maps, When I went to map 2 i spawned in the air
Then i made new map and recreated trigger_changelevel

I found out that even though I set it to a different map, it teleported me to the old map 2, as if the first map hadn't been saved.
I tried to copy and paste the first changelevel map to another save but when I wanted to test it, it wrote "Map not found" to my console
Then I tried to save it but even if i compile it, it doesn't work

[moderator note - moved here from another new thread]
Posted 3 months ago2021-01-13 06:37:17 UTC Post #345212
Stop creating duplicate threads please. You have one issue, please keep it in one thread. I've moved your other post into this thread.
Penguinboy PenguinboyHaha, I died again!
Posted 3 months ago2021-01-14 09:21:33 UTC Post #345218
Okay, im sorry
You must be logged in to post a response.