Sledge (Hammer Alternative) Alpha Build Created 6 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Created 6 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Posted 5 years ago2014-06-02 19:40:23 UTC Post #319637
Aw, I didn't think to flip the normals in the 3d program. Seems still tedious but may have pretty ok results after I track down all of incorrect faces.

A tetrahedron has the minimal amount of faces and can be morphed nearly any way as long as it doesn't invert its faces. Importing quads (squares or polies) could cause errors if not co-planar. Also, using a BEVEL texture on the backside has some effect on it. Don't quote me on this, but I think its the most optimized way for collision hulls. Using them in a displacement or terrain setting keeps the number of hulls low so you don't run out.

I guess my point is that we shouldn't have to do all this to make it work. I have a pretty extensive knowledge of mapping, compiling, optimizing, and 3DS Max. These troubles would be an immediate negative if someone tried this and was new to any of it.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-06-02 22:09:40 UTC Post #319639
Well, it is not a feature intended to be used by beginners. OBJ uses the order of vertices to specify face directions, so setting the normals to point outwards needs to be done (it's not possible to magically predict which direction you intended them to face).

Quads and other face types are supposed to work, but I'll need to investigate why they're not working using your examples.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-03 02:48:26 UTC Post #319640
PB,
What software did you use to make your test objects?
What version of that software?
What were your test objects?
What export settings, if any, did you use for your OBJs?
Was the OBJ file compressed in any way from the 3D software?
Was the scale accurate to the one in your 3D software?
Was the imported OBJ rotated properly?
Did you check for errors?
If yes, what were they?
Did you test the really large and really small OBJ geometry?
Did you test if any texture coordinates confused the geomerty on export/import?
Did you re-import the OBJ from Sledge to your 3D software to confirm accuracy?

I've been at this for a while...
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-06-03 03:23:22 UTC Post #319641
OBJ is an incredibly simple format, especially since so much of it cannot be applied to Sledge since it involves free-form geometry and curved surfaces. Sledge ignores surfaces, curves, materials, and material coordinates.

To answer your questions...
  • I downloaded test objects from the internet
  • N/A, see above
  • I used a 20-sided regular polyhedron (an icosahedron) to test importing of a single convex solid (this is the only time Sledge will create a complex solid from an import), and the other test I used was a large array of quads (~110k faces) exported from a minecraft map. I tested a few others for once-off tests but those were the main two I tested on.
  • N/A
  • The OBJ standard doesn't have any information about compression, I don't know what this means. If it's just simple sharing of vertices or polygon decimation, this is just additional complexity on the exporting program and doesn't impact the object consumer.
  • The OBJ doesn't support specifying a scale. I multiply all values by 100 because the samples i tried exported on a much smaller scale than a standard map.
  • From what I can see, the OBJ doesn't allow a transformation to be applied to a group of objects. Goldsource/Source uses a Z-up coordinate system, so if you're working in a Y-up environment you will need to rotate the object before you export, or after you import.
  • Yes, no errors occurred for my test cases
  • N/A, see above
  • Yes, one of my test cases was very small (1 unit) and one was quite large
  • Texture coordinates in the OBJ format are stored as U/V coordinates which are incompatible with the axis system in GS/Source. Textures are aligned to face instead.
  • The result will be unavoidably different due to faces being turned into solids when the file is imported into Sledge.
As I said before, I will need to investigate using your sample files from before. I'm sure there are bugs in the import process, so please don't stress out so much...
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-03 10:08:28 UTC Post #319643
Another thing I find kind of inconvinient is the locked 15° 2d view rotation snapping, I most often need multiples of other values than 15.
Posted 5 years ago2014-06-03 11:20:53 UTC Post #319644
15 degree snapping is set up exactly as it is in Hammer 4, and you can use shift to override it. It's also toggleable to switch it off in the 2D view options.
Archie ArchieGoodbye Moonmen
Posted 5 years ago2014-06-03 11:49:10 UTC Post #319645
I think the idea is that it could be useful to snap to other increments like 5 or 10 degrees.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-03 12:41:07 UTC Post #319646
What Penguinboy said. Rotating stuff without any degree of snapping is no good. Another thing I'd like to see is object vertex to object vertex snapping (might just be me that haven't found the feature, though) since 1 unit grid snapping or 0.1 unit nudging sometimes isn't precise enough.
Posted 5 years ago2014-06-03 23:37:41 UTC Post #319647
Your answers provide a ton of insight.
The reason its scaled weird is probably because your original OBJs were made on alternative units. Like instead of 1 to 100, its 0 to 1 with lots of decimals. Like perhaps Maya and maybe something else was used.

This is the mesh I'm trying to import. It's perfect in Max but in Sledge, not so much. https://www.dropbox.com/s/uu6fh2lzm5xrnzs/cave%20mesh%20final.obj

EDIT: The more I use Sledge, the more I like the sort of preview you get when you go to create new arches and torus.

Take or leave it, may I suggest that there can be a OBJ importer (with options dialog) that allows the user to preview the result, scale it, and do whatever before it commits to being turned into brushwork. This could be a tool with the brushwork stuff, or a feature under the file menu, doesn't matter. These options could also help distinguish between using Triangles and Quads. Once source stuff is implemented, I'd love to loosely rough out the terrain in 3D then port it over and convert it to displacements for smoothing and sculpting. As you know, displacements only work on brushes with 4 sides.

PB, I'm really passionate about Sledge's development (in case you didn't notice). Never more in my life I wish I could code so I could help this out. It's a good thing and I want to see you make it the new standard in Goldsource/Source/Source2 mapping.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-06-13 17:46:34 UTC Post #319768
perhaps you have already noticed, penguin, but a new issue that ive been having when using the texture application tool (since the new update that kinda messed things up a bit), is that when i use the ctrl + right click function when applying a texture, the texture reverts BACK to a previously selected texture instead of keeping the current texture. not sure why this happens, it didnt used to. just something to be aware of! cant wait for the new release/fix so that i can start really using sledge again (a few projects had to be put on hold because of the wad black/whitelist being broken)
Posted 5 years ago2014-06-14 16:47:02 UTC Post #319776
I'd like to report a RMF compatibility problem - You cannot open older formats such as version 1.8 - The version of RMFs included in the Half-Life SDK.
JeffMOD JeffMODCall 141.12
Posted 5 years ago2014-06-15 01:33:18 UTC Post #319780
Yes, unfortunately it's a reasonable amount of work to get those working, so at the moment I don't plan to support them. You can open and re-save the map in Hammer to convert old RMF formats to RMF 2.2. I might look to support the older formats once the program has Source support and is in a stable state.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-15 02:34:17 UTC Post #319782
What's so different about those?
Posted 5 years ago2014-06-15 03:35:51 UTC Post #319783
RMF is a binary format made from serialised C structures, which means that every time there's a version change, pretty much every structure changes too. It'd be reasonably time consuming to reverse-engineer each different format to figure out the differences in each one, and then add support for them into the application. It's certainly not impossible, but it's difficult and it would take a pretty large chunk of time for each version change (I have encountered at least 3 different RMF version numbers, there's probably more).

What makes it harder is that certain RMF version numbers belong to versions of Worldcraft that don't seem to exist anywhere on the internet, which means I have to guess values instead of doing a proper reverse-engineer. Depending on how much has changed in each version, it might be much easier or harder than I think it is.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-15 03:39:06 UTC Post #319784
Surely older RMF versions is an issue that won't come up THAT often. As a feature, it seems very much in the realm of want-to-have rather than need-to-have.
Jessie JessieLadytype
Posted 5 years ago2014-06-15 04:15:12 UTC Post #319785
In other news, I've just published a new release! I've fixed the lag when selecting textures, and the texture black/white lists and favourite textures now work. I've also made a change that should fix most of Rimrook's errors when importing OBJ files.

The biggest change that I've made is that the sidebar is now more dynamic: only the panels that are valid for the current tool are shown. There are sidebars for the select, entity, brush, texture, and VM tools, and I will add more as they are needed. The texture, visgroup, and a new contextual help panel are the only ones that are always visible. If you don't like any of these panels, just minimise it and it will stay that way.

Archie will be happy to know that I also added the two oldest feature requests in the new "Texture Power Tools" sidebar (visible when the texture tool is open):
User posted image
Full change list:

UI change: Dynamic sidebar
  • Added dynamic sidebar panels
  • Added texture power tools sidebar panel (randomise shift values, tiling fit). Fixes #8, fixes #9.
  • Brush selection panel now only appears when the brush tool is open
  • Entity selection panel now only appears when the entity tool is open
  • The VM tool window has been moved into the sidebar
  • Added sidebar panel for the selection tool
  • "Tie to Entity" and "Move to World" buttons moved to the selection tool panel
  • Added contextual help sidebar panel
Bug fixes
  • Fix favourite textures so they work again
  • Focus the close button on load in the check for problems dialog
  • Fix the blacklist and the whitelist so they save and load correctly
  • Select all the text in the numeric controls when tabbing through the texture application form
  • Optimisations related to models and textures
  • Fix an issue causing a lot of invalid solids when opening OBJ files
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-15 06:05:12 UTC Post #319786
Unlimited zoom for 2D and 3D views it's a bug or feature?
Posted 5 years ago2014-06-15 07:04:18 UTC Post #319787
Wow, finnaly you have fixed that texture lag bug. It was getting on my bad side. Sledge is becoming into something, that is already better than all VHE's together :D
Posted 5 years ago2014-06-15 12:47:20 UTC Post #319790
User posted image
Archie ArchieGoodbye Moonmen
Posted 5 years ago2014-06-20 10:38:29 UTC Post #319900
Sledge is an incredibly functional editor. I know this because I trust it.
Pb, I feel better about launching Sledge than I do about Hammer!
All I can say now is, thank you for your hard work. I know you didn't do it for me, but thank you. This thing is great.

One little tiny flaw that shouldn't matter, if you do a horizontal or vertical flip on an invalid brush, the faces reverse.
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-06-20 10:46:39 UTC Post #319901
Thanks Tet, that makes me feel all warm and fuzzy :)
Are you still mapping in Goldsource land? I would have assumed you were fully invested in Source by now. Hopefully Sledge can support both in the near future. (Though I'm taking a break from Source stuff and bugfixing for now so I can look at adding peer-to-peer networked multiplayer editing.)
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-20 10:59:07 UTC Post #319902
Yay, finally, multiplayer mapping. Actually, more like a multideveloper :D
Posted 5 years ago2014-06-20 12:35:24 UTC Post #319904
I'm mapping at work to map on my break/lunches. I'm making soccer arenas for a source mod. The rotate gizmo has saved me hours of fine tweaking already.
Once I have the basics laid out in Sledge, I plan to import the map into 3DSMax to make models of railings and some of the more detailed bits.
After that, send it to Source and re-texture it. It runs flawlessly on my work machine which is sub-par by my standards.
User posted image
Red - Seats
Orange - Walls
Blue - Stairs / Floor
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-06-20 13:20:17 UTC Post #319905
That's pretty neat. You can increase the size of the grid in the settings, btw. Or just load a Source FGD.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-06-20 13:48:17 UTC Post #319906
something i noticed when using the vertex tool lately is sometimes when you select a brush and select another one (not both at the same time), the first brush becomes invisible. its still there and selectable, just invisible. eventually it comes back after a few times selecting and deselecting it but its still a strange one.

also im still having this weird texture issue. any time i want to use a "recent texture" on the right hand side of the texture application tool box, i have to continually reselect that recent texture after every single face that i apply it to. for example, if i used Null recently and i wanted to select it from the recent textures and use it to texture a brush, every time i select it and apply it to a face, sledge reverts my selection back to whatever textures are in the 'main' area of the texture app tool (the one that shows what textures are active on a given brush).

it even does it if NO textures are in the 'main' area. i hope im making sense, its a rather strange bug but its annoying enough to note since it didnt used to do that before
Posted 5 years ago2014-06-20 16:52:53 UTC Post #319918
something i noticed when using the vertex tool lately is sometimes when you select a brush and select another one (not both at the same time), the first brush becomes invisible. its still there and selectable, just invisible.
Yeah i got that one too a few times.
That and every time i close sledge, windows throws me an error
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-06-20 19:45:56 UTC Post #319925
That's a nice stadium!

@PB I can't help but wonder what multiplayer mapping would be like.
Posted 5 years ago2014-06-22 18:43:44 UTC Post #319936
Very nice, like it it a lot-- just can't figure out prefabs ;__;
Posted 5 years ago2014-06-24 19:05:44 UTC Post #319976
Autodesk style
User posted image
User posted image
Posted 5 years ago2014-06-24 20:14:57 UTC Post #319977
Hopefully PB keeps Sledge iterations in version numbers instead of years.
I mean really whats with the trend of going to year iterations, i loved everything being ordered nicely in version numbers that way i know i have the latest or not.
rufee rufeeSledge fanboy
Posted 5 years ago2014-06-24 22:23:41 UTC Post #319978
Completely redundant having Logic&Trick in the title of the application and the developer bumper. Just have it once.

The image of the house is also not in any way related to Sledge and does not symbolize the Sledge editor. Needs to be a central concept behind Sledge.
Crollo CrolloTrollo
Posted 5 years ago2014-07-02 17:56:16 UTC Post #320028
I've found a couple things that don't match expected behavior coming from Hammer to Sledge - first off, texture lock (regular texture lock, not scaling) seems a bit different - instead of just preserving texture orientation relative to the brush when moving, it also tries to keep the texture where it was relative to the edge you're dragging - however this is inconsistent depending on which edge you're dragging.
User posted image
I can see the 'edge preserve' thing coming in handy if it's applied to all edges, but IMO it should be separate from the traditional "movement" texture lock.

Also, when dragging and entity or brush edge in the 2D views, it seems really speedy compared to Hammer - and a bit hard to control for me. Could we maybe have that be configurable like the 3D view speed?

EDIT: Also, it seems that occasionally pasting brushes using paste special will change the texture alignment of corrupt and make unselectable the copied brush.
Or this may have something to do with grouping brushes in a way that makes the group concave, such as having tilted wall surfaces along with a section of floor.

EDIT4ish: I think the selection thing is because of concave groups, (which turn out to NOT be corrupted, merely unselectable, forcing selection of brushes/faces on the outer bounding box of the group only) while the texture alignment thing may be non-90 degree angles.

EDIT: I'm also getting odd behaviour where both the "world" and "face" checkboxes in the texture application window are ticked, but seem to have no effect, making it very hard to apply textures that have text, such as signs and posters, properly. Oddly enough, swapping to another texture and then back has a chance of solving the problem - so long as you don't accidentally click the "face" checkbox, which will align it to what I presume is world again.

EDIT: I've just enconutered a bug where Sledge will ocassionally, when not the active window, still accept camera commands from WASD. I was using Skype at the time. Have not been able to replicate it. :\

There's also this, which has been confusing and frustrating me to no end.
User posted image
I can fit it just fine in the editor,
User posted image
But ingame the texture is misaligned. It's probably because the face is slanted, since I'm able to fit-justify things on 90-degree faces properly.
JeffMOD JeffMODCall 141.12
Posted 5 years ago2014-07-03 14:52:57 UTC Post #320095
i had the texture problem as well (the misaligned one) jeff. its because sledge takes the decimal points too far and thats what makes it misaligned.

you need to make sure to only take the decimal point to the hundreds place. so in your case ".43" and ".33" and it should be fine.
Posted 5 years ago2014-07-03 17:51:08 UTC Post #320097
Alright. Thanks for the tip - that fixes about half the problems I was having with the map I'm working on!
JeffMOD JeffMODCall 141.12
Posted 5 years ago2014-07-03 22:30:22 UTC Post #320099
goodie gumdrop!
Posted 5 years ago2014-07-04 18:38:55 UTC Post #320114
Found another bug - Using the file browser to select models includes the models/ directory in the path, which is what the game requires. However, selecting sounds with an ambient_generic will include the sound/ directory, which will make the game search for sound/sound/[sound location] - so it doesn't play ingame without manual editing.
JeffMOD JeffMODCall 141.12
Posted 5 years ago2014-07-05 03:54:25 UTC Post #320118
It is the game that is inconsistent, so it is the game that should be updated to address this.
Posted 5 years ago2014-07-05 04:27:06 UTC Post #320119
Haha. I wish :P
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-06 04:02:56 UTC Post #320140
i had the texture problem as well (the misaligned one) jeff. its because sledge takes the decimal points too far and thats what makes it misaligned.
Haha, holy smokes, I didn't think you could get too precise.
Posted 5 years ago2014-07-06 20:44:09 UTC Post #320149
We already have one of these,
User posted image
Could we also get these?
User posted image
Translate/move
User posted image
Scale, or something like it that would work for skewing.

And this might be a missed thing but I had a bunch of lights, and I went to the entity to select them all to change their color. I couldn't multi-select and do that. I had to do it one at a time. I had to open Hammer to do this quickly, sorry.

Also, why not this? It's just practical.
User posted image
EDIT: forgot to add a browse button to find the OBJ but you get the idea.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-07-07 00:05:28 UTC Post #320150
On the subject of rotation, I've been having issues where it doesn't actually set an entities' yaw, instead just moving the model/sprite around on the axis and then reverting when you let go of the mouse.
JeffMOD JeffMODCall 141.12
Posted 5 years ago2014-07-07 15:35:28 UTC Post #320160
I can apply point entities to a brush (and vice-versa) and it gets a little buggy.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-07-07 22:35:34 UTC Post #320164
I've started fixing some bugs yesterday after taking a bit of a break, so hopefully I can get some of these bugs fixed soon :)
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-07 23:25:21 UTC Post #320165
I would love to see John Guthrie from Valve get fired for using Sledge one day.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-07-08 04:31:34 UTC Post #320166
one annoying bug ive been dealing with is a weird texture one where sometimes when i open sledge, certain textures will mysteriously change size/dimensions. for example, 1 texture (a bulletin board texture) is 96 x 48. however, after closing and opening sledge, SOMETIMES it will say the texutre is 128 x 64 and therefore be misaligned (in sledge AND in game after a compile). it happens with a few other ones as well. at first i thought it was because there were duplicate texture names and sledge was just choosing one but i checked and rechecked and found no duplicates. im not sure what the cause of this might be but it just seems to pic textures to mess with at random.
Posted 5 years ago2014-07-08 09:22:00 UTC Post #320167
Those are intriguing numbers, I would suspect it has something do with with the fact that Sledge automatically resizes textures to powers of two (e.g. 16, 32, 64, 128) when your graphics card does not support non-power-of-two textures. However I can't find anywhere in the code where the resized size could possibly be used by accident (it's only temporarily used to upload to the GPU and then it is discarded, so there's not a lot that could go wrong).

Can you consistently get it to happen, or can you manage to find some sort of situation where it always happens? It will probably only happen on textures that aren't powers of two (your 96x48 texture is a good example), so hopefully that can help you narrow it down. If you can find a way to consistently replicate the issue, I can then try to do the same on my PC so I can try and fix it.

What model is your graphics card and what renderer are you using in Sledge? Can you post a screenshot of the texture and how it displays with the wrong size? Screenshots of the incorrectly-sized texture in the texture browser and the texture properties dialog might be helpful.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-08 14:58:10 UTC Post #320168
yeah i know exactly what textures it does it on cuz its the same ones everytime (with the exception of a new one that i tried to use later on in the map).

so far only 3 textures have done it so far.

my card is a gtx 570. im not sure what you mean by what renderer am i using in sledge :z

ok here are the screen shots

these 2 show the texture as it SHOULD look with normal dimensions.

DOOR (48 x 96)
http://i.imgur.com/8Kj2WHr.png

BULLETIN BOARD (96 x 64 - i gave you the wrong dimensions in my other post, sorry)
http://i.imgur.com/J98JQES.png

here are the textures misaligned with the wrong textures displayed in the TA box

DOOR
http://i.imgur.com/aX58Db5.jpg

BULLETIN BOARD
http://i.imgur.com/dZxKobW.png

here are the normal textures in the browser, note the highlighted sizes

DOOR
http://i.imgur.com/u51rnBQ.jpg

BULLETIN BOARD
http://i.imgur.com/qtfgImC.png

and finally, the incorrect textures with incorrect texture sizes

DOOR
http://i.imgur.com/8ruGFoW.png

BULLETIN BOARD
http://i.imgur.com/UrJQ9iD.png
i opened sledge to take the screen shots and the textures were fine and normal. when i closed sledge and reopened it, they were incorrectly sized and stayed that way UNTIL I RESIZED ONE TO FIT THE BRUSH IT WAS APPLIED TO. only then did it revert back to normal after reopening sledge. i made sure to open and close sledge multiple times without fitting the incorrect texture (with no change) just to make sure that refitting it was indeed what causes it to revert back.

both of these textures are from the default halflife wad file so you should have them somewhere in your arsenal. there may be other textures that behave this way as well, there was one other for me but i stopped using it when it gave me other errors.

oh and one other bug thats been, well, buggin me is sometimes when i group brushes into a group, it turns them black in the 2D views and no matter what i do they never go back to normal color. ungrouping them does nothing, even copying the brush with shift click (or whatever) doesnt help. you can actually see an example of this in the first screen shot, there is an area in the TOP grid view, its off to the left where it looks like entity brushes are just out in the void. the brushes there are black from being grouped ages ago and still have never fixed themselves.
Posted 5 years ago2014-07-09 09:47:48 UTC Post #320175
Can you tell me how to setup sledge for TF 2. I cant get it to register most of the TF 2 stock textures.
Posted 5 years ago2014-07-09 10:02:15 UTC Post #320176
Unfortunately Source is not supported yet, so you won't be able to use displacements, instances, or even compile with the Source tools yet.

You should be able to load TF2 textures (this is not recommended, Source is not officially supported yet!) by using these game settings:

Steam install: NO
Game dir: steamapps/common/Team Fortress 2
Base game: hl2
Mod: tf
Entities: add tf2.fgd

It may take a few minutes to load the textures, I haven't worked out how to speed this up yet.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-09 11:50:21 UTC Post #320177
I've started fixing some bugs yesterday after taking a bit of a break, so hopefully I can get some of these bugs fixed soon
Sweet! New version of Sledge is always a good thing in my book!
I would love to see John Guthrie from Valve get fired
:aghast:
JeffMOD JeffMODCall 141.12
You must be logged in to post a response.