Sledge (Hammer Alternative) Alpha Build Created 5 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Created 5 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Posted 5 years ago2014-07-09 12:09:38 UTC Post #320178
Can you tell me where to find teh tf2.fgd file?
Posted 5 years ago2014-07-09 12:13:25 UTC Post #320179
I bet valve would love sledge :)
rufee rufeeSledge fanboy
Posted 5 years ago2014-07-09 12:16:36 UTC Post #320180
Sorry, it's just 'tf.fgd' and it can be found in: steamapps/team fortress 2/bin
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-09 12:32:57 UTC Post #320181
Yes it works fine now. I use a program called Valve Batch Compiler Tool for my build tools anyways.

Thanks for making this program. I have been using it along with custom textures that I use. I like how your program does the texture alignment.

I like Sledge and I will give it to my friends.

I hope that source will be added in some day.
Posted 5 years ago2014-07-09 15:52:45 UTC Post #320188
Don't worry, Source support is right around the corner. Hopefully.
Posted 5 years ago2014-07-10 16:00:38 UTC Post #320206
Sledge hasn't been good to me lately. In entities like ambient generic, it's been forgetting which flags are checked when opening a .map file.
Rimrook RimrookGoldsource Guru
Posted 5 years ago2014-07-10 19:42:29 UTC Post #320208
Good to know Rim. I've only really done brushwork so far in Sledge, but I have some entity setups coming up..

Is the Sledge compile thingie functioning? I tried it before, but it think my config was messed up...
Captain Terror Captain Terrorwhen a man loves a woman
Posted 5 years ago2014-07-10 20:38:42 UTC Post #320212
sledge also has a nasty habit of forgetting your "map properties" settings. i just finished a map

(http://cs.gamebanana.com/maps/181666 SHAMELESS PLUG)

and when i set the skybox texture, it would revert back to some default one everytime i closed and reopened sledge.
Posted 5 years ago2014-07-10 21:57:33 UTC Post #320213
Are you using VMF or RMF (or both?) when it forgets the map properties?
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-11 06:13:49 UTC Post #320224
vmf for this particular instance, i dont recall if this problem occurred with rmfs
Posted 5 years ago2014-07-11 08:26:32 UTC Post #320226
Why can't all bugs be as easy to fix as those two? :P

Both these problems are fixed in the next version:
  • When opening a .map file, entity flags are not loaded
  • When saving a .vmf file, some worldspawn properties like "skybox texture" are not saved
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-11 13:04:48 UTC Post #320230
awesome heh. for some reason it takes a really long time to open the texture browser now that the new system of detecting wads has been implemented. i use the whitelist feature so im not loading hundreds of wads, but even then its still slow. is it just cuz it needs to filter out all the unused ones everytime? or is it something else slowing it down.

also, i mentioned this bug in an earlier post but i figured out how to consistently recreate it i guess: if you select a texture directly from the texture application tool box and try to apply it to a face (whether with alt + right click or just right click) it will apply ONCE then revert back to either a previously selected texture or no texture (if none was selected).

sorry if it's already on your list of things to fix but i just dont want it to be forgotten cuz its pretty annoying.
Posted 5 years ago2014-07-11 18:55:54 UTC Post #320232
It's a good bet you broke the whitelist with all those wads(was it fun typing them all in, or can you blanket select them somehow?).

I remember Atom's LaunchPad lagging for me hardcore, because my entire map archive was in one directory, lol.

I haven't experienced this lag yet, but I'm fortunate to have Sledge installed on a fresh setup(only 10 wads in my valve directory) :)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 5 years ago2014-07-11 19:43:02 UTC Post #320238
i only use 25 on the whitelist but i have hundreds in all the folders that sledge checks. and yeah i had to type them in but its no biggie
Posted 5 years ago2014-07-11 20:13:56 UTC Post #320241
Er... still can't figure out prefabs. Can anyone help me out?
Posted 5 years ago2014-07-12 19:55:59 UTC Post #320255
Compiling through sledge.. func_doors.... master is null or not a master.
Doors don't work. wat?
Func_walls not showing up...
Lights placed within ~64 units of eachother not rendering..
Something's afoot.
more details....
Using the compilator instead of sledge to compile.
Using halflife.fgd located here: http://themightyatom.nl/downloads.html

I have a simple func_door, set to have a lip of 2 with no master set (field is blank).
When i compile and play, the door does not open and the game returns "master is null or not a master"
HOWEVER
If i tick the "use only" flag, the door opens when i play the game yet NO FUNC_WALLS RENDER!?

This is quite odd.
Tested map with hammer 3.4
Created new door, exported to .map, compiled with compilator - works fine.

Something to look into PB
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-07-12 22:44:27 UTC Post #320260
That is pretty odd, Tetsuo, which compile tools are you using? I just tested it myself and I can create func_doors and func_walls (both with default properties) and they work in-game correctly. Can you send me the .map file that Sledge generates and the .map file that VHE generates so I can compare them?
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-13 00:09:43 UTC Post #320264
Compile Tools: Zoners 3.4 64bit - LINK if you're interested.

Screenshots:
Here's a screenshot of an error relating to the player start - seemingly unrelated to the door not having a master.

Here's an error displayed in game after trying to activate the door by touch, and then backing off.

Link to Map: Please Click here (VMF) Right-Click, saveas, else it'll open as a text file.

Steps to re-create:
  • Create two rooms with connecting hallways
  • - I made a block, hollowed it, cloned it, created a connecting hallway.
  • Create a player start and a point light in each room
  • Create a brush sealing off both rooms
  • - Tied said brush to func_door, made it move vertical, lip of 2.
  • Compiled
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-07-13 00:51:21 UTC Post #320266
Are those tools on Atom's page the ZHLT final(y/n)? (I think those were the last used when I was actively mapping GS, and they worked great)

If y, consider giving the latest Vluzacn's ZHLT 3.3 a try, as I think they are consiered the best version of the tools? Someone plz correct me if I'm wrong ;)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 5 years ago2014-07-13 02:01:31 UTC Post #320268
Hmm I haven't gotten 3.3... I just got sledge, and remembered that Atom hosted lots of goodies
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-07-14 08:30:17 UTC Post #320287
Ok Tet, I've taken a look at the problem and I've fixed it in the next version, but in the meantime, upgrading to the more recent VHLT tools that CapT linked above will also fix the problem. I also fixed the "invalid key/values" error in the "check for problems" window.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-14 13:17:45 UTC Post #320296
Noted. I got the new ZHLT :)
Thanks PB!
I'm curious as to what caused that problem though.
Tetsu0 Tetsu0Original Cowboy
Posted 5 years ago2014-07-14 14:19:58 UTC Post #320297
Zoner's tools (ZHTL) and Vluzacn's tools (VHLT) are not the same thing, though I believe the latter is based on the former, albeit vastly improved.
Archie ArchieGoodbye Moonmen
Posted 5 years ago2014-07-14 14:32:34 UTC Post #320299
is there a way to limit each error popup to 1? its sooooo annoying when 400 pop up in 2 seconds, causing me to either have to sit there and click each one closed or close sledge altogether.
Posted 5 years ago2014-07-15 21:07:36 UTC Post #320344
Does the Sledge Editor include support for Heretic 2 and Hexen 2?
If not, could you add support for them?
These games are built using the same engine as Quake 2, Id Tech 2.
Posted 5 years ago2014-07-15 23:34:13 UTC Post #320349
It doesn't at the moment, but it would be cool if it did. I don't know anything about Tech 1/2 mapping and how different they are to Goldsource, so it's not something I can just add without putting in a lot of research. I am focusing more on Source support, but if anybody has experience with programming and Quake 1/2 mapping, I think adding support for those engines wouldn't be a huge effort and I would be more than happy to help with the coding side of things!
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-16 03:11:02 UTC Post #320352
The GoldSource Engine is just a modified version of Id Tech 2.
And Id Tech 2 runs Quake 2, Hexen 2, Heretic 2, and several other games.
Posted 5 years ago2014-07-16 05:06:08 UTC Post #320354
Yes, but as far as I know it also has several major differences when editing. Something about material flags that need to be set on faces, and the .map format is different as well (specifically to do with texture axes). And I'm also not sure how Quake 1/2 games specify entity data, because I think the FGD format is a Hammer thing.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-16 16:15:51 UTC Post #320360
Thank you for your time.
But doesn't your program allow you to import Quake .map formats?
Posted 5 years ago2014-07-16 22:50:15 UTC Post #320372
I think it does, because WinBspc uses Quake-style .map format rather than the Goldsource format. However, Sledge doesn't currently save .map files in the Quake formats, which I think the Quake compile tools would need to work. I am planning on adding a sort of "engine feature detection" thing when I add Source support that automatically detects how to load/save maps depending on the selected engine. I will try to keep the older Quake engines in mind when I'm doing that so it's easier to add support for those games.
Penguinboy PenguinboyHaha, I died again!
Posted 5 years ago2014-07-17 06:59:07 UTC Post #320387
Not to be the captain here, but GS is built on IdTech 1 with some Tech 2 code. In a sense Tech 2 would be superior to GS if not for the Valve innovation.
rufee rufeeSledge fanboy
Posted 4 years ago2014-07-19 13:03:31 UTC Post #320451
Very first Compile in Sledge, and it went perfectly! :P

User posted image


After selecting the wads properly out of my valve directory, everything worked stock! Easiest compile setup ever, Well done PB!

No errors except my own, such as making the transparent textures the right rendermode and adding lights! Sledge even preserved all my crazy brushwork: look at the spheres!

Everything looked on the grid where I left it, so the floating point thingie works perfectly too! :o

I :heart: Sledge =P
Not to be the captain here...
HOW DARE YOU
:P
Captain Terror Captain Terrorwhen a man loves a woman
Posted 4 years ago2014-07-19 13:21:59 UTC Post #320459
Hahaha Captain :)
How many Natural Gas meters do you need!? (texture on wall, right-center beneath top support beam)

I smell great potential. I'm excited to see how you light it!
Tetsu0 Tetsu0Original Cowboy
Posted 4 years ago2014-07-19 13:34:54 UTC Post #320461
Yeah! I didn't realize it was a randomly tiling texture, LAWL! :P

Anyone!
About to try some texlights in Sledge, is there anything special I need to know, or any tricks/features Sledge might have for them?
Captain Terror Captain Terrorwhen a man loves a woman
Posted 4 years ago2014-07-19 13:39:43 UTC Post #320462
I had an error a few minutes ago where using the arrow keys to nudge a particular group of brushes (containing no entities) caused the crash dialogue to pop up. Opening the error window showed a few instances of the group has no children error. Deleting these fixed the problem, however I also encountered a bug with these.
If instead of deleting them I selected 'Go to error' on any of the instances, then the 3D view would go black. Pressing 'Z' to look around in the 3D view would cause an infinite loop of crash dialogue boxes to open up.
Changing the 3D viewport to a 2D view, then back to 3D would allow me to look around without crashing, however none of the contents of the level are rendered, making it appear as if it's an empty level.
Posted 4 years ago2014-07-19 14:22:47 UTC Post #320463
Captain Terror Captain Terrorwhen a man loves a woman
Posted 4 years ago2014-07-19 14:53:55 UTC Post #320464
Hahaha! :aggrieved:
What a silly error.
Sledge is fantastic and all, but it still has some odd quirks about it that make me run to hammer for the nitty-gritty stuff
Tetsu0 Tetsu0Original Cowboy
Posted 4 years ago2014-07-21 22:09:03 UTC Post #320580
Lot of bug reporting lately, I feel like a feature request is long overdue!

This one might be a pipe dream, but bear with me. If it's doable, it'll blow the pants right off you with awesomeness.

Is there a way? IS THERE A WAY? Is there a way we could preview train and door movements in-editor in order to fine-tune parameters such as speed and acceleration? I'm thinking a 'ghost' version of the entity follows its paths and disappears when something else is clicked on, or maybe even loops whilst live updating? Is that too silly?
It's crazy, I know, but it's that sort of crazy which also seems vaguely feasible.
Archie ArchieGoodbye Moonmen
Posted 4 years ago2014-07-21 22:29:20 UTC Post #320581
That would be neat Archie, 'specially for the trains! Even a red blinking sprite tracking down the path would be sweet. (connect the path with lines like it does in Hammer 4)

With as good as Sledge is getting, you have to wonder if the Valve dev's have a Deluxe version of hammer with much more capability(and we pleebs get the chopped/bugged beta ;))
Captain Terror Captain Terrorwhen a man loves a woman
Posted 4 years ago2014-07-21 22:30:23 UTC Post #320582
OMG I WANTED THAT FOREVER!
UE3 kinda had that with movers.
Tetsu0 Tetsu0Original Cowboy
Posted 4 years ago2014-07-21 22:57:31 UTC Post #320583
I had this same thought when I watched your tutorial of the "map evolution" videos, Archie. It's definitely something I'd like to do when everything is nice and stable :)

In other news, I got a fun suggestion from Alberto to add a "text" brush type - as in, you select your font and type the text you want, and the text is turned into (unavoidably inefficient) brushwork. I've got the basics set up and it was surprisingly easy to add :) I can provide screenshots when I get home if you're interested in seeing what it looks like.
Penguinboy PenguinboyHaha, I died again!
Posted 4 years ago2014-07-22 02:03:51 UTC Post #320600
Another request: Assignable hotkeys to rotate 90 degrees (C)CW on the 3 axes. I've a macro assigned to do that with Hammer, and it's amazing how much of a time-saver it is.
Crypt Crypt120% sorry!
Posted 4 years ago2014-07-22 02:28:44 UTC Post #320601
There are macros in Hammer?
Posted 4 years ago2014-07-22 02:49:16 UTC Post #320602
No, I just have a keyboard with macro support. Native hotkeys for common operations like this would be nice.
Crypt Crypt120% sorry!
Posted 4 years ago2014-07-22 04:10:48 UTC Post #320605
What does your macro do? I'm really curious about this. I didn't think there was a way to rotate things with just the keyboard.
Posted 4 years ago2014-07-22 08:42:47 UTC Post #320610
Screenshot as promised:
User posted image
Penguinboy PenguinboyHaha, I died again!
Posted 4 years ago2014-07-22 08:48:21 UTC Post #320611
Ooooh, fancy.
What does your macro do? I'm really curious about this. I didn't think there was a way to rotate things with just the keyboard.
Clockwise on Z Axis:
CTRL+M
TAB (x3)
9
0
ENTER
I noticed this doesn't work in Sledge without a bunch more Tabs.
Crypt Crypt120% sorry!
Posted 4 years ago2014-07-22 10:20:29 UTC Post #320612
Once you get the displacements implemented in GS, any chance of having an option to use blend textures for them? Even if that would mean saving each blend for it's particular mesh; perhaps something in a 256x256 size, or optional size? I guess in 2014 it's safe to go outside 10 Mb texdata? :P
Maybe something similar to Vluzacns way of saving textures , in v33, when using 'zhlt_embedlightmap'.
Posted 4 years ago2014-07-22 10:39:45 UTC Post #320613
Hmm, it would have to generate the in-between blended textures automatically into a custom wad file and then automatically -wadinclude that when you compile. That's not the kind of thing I want to add because it breaks portability and compatibility with other tools, so I don't see something like that being added as a main feature.
Penguinboy PenguinboyHaha, I died again!
Posted 4 years ago2014-07-22 16:51:46 UTC Post #320631
Err, I keep running across a problem where certain brushes become unselectable from any viewport... is this supposed to happen (as in, is there a key I pressed by accident).
You must be logged in to post a response.