Sledge (Hammer Alternative) Alpha Build Created 7 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Created 7 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Posted 7 years ago2013-07-31 08:22:27 UTC Post #314606
Awesome. I was wondering when you were going to drop this corker. I look forward to the Source release, let me know when it's up. I need a good alternative to the broken Source SDK and Hammer.
Posted 7 years ago2013-07-31 08:50:11 UTC Post #314607
@Stu: To be honest I just copied Hammer's zoom behaviour which is to multiply the current zoom by 1.2 each time. I could make that a configurable option, but since the zoom is a multiplication option you'll pretty much always get odd values, for example: 1/1.5/2.25/3.375/etc - unless 2 is the multiplier, which will result in 1/2/4/16/32 - however these zoom amounts are too large and are not very useful. Since zoom amount is largely arbitrary, Hammer's default zoom value seems to make sense to me.

The grid thing is a bit of a pain - I don't know how I'll get my hands on the right hardware to debug that one. It's in the bug list and I'll try and get it sorted as soon as I can. For the 3D grid - I just had a look, and 3D grid isn't rendering properly when no textures are loaded. Can you set up some WADs if you haven't already and let me know if you can see the 3D grid? That would make it a reproducible bug (since I just reproduced it) :)

Cordon doesn't render yet - it's in the next build, along with decal rendering, entity sprites, hide face mask, and transparent tool textures. I'm aware of the non-perfect selection handles, I'll add it into the bug list.

@Hotdog: Thanks, will do :P
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-07-31 12:39:46 UTC Post #314614
Yay tool tips labels! =PP

A couple teaser bugs:
  • Used textures only option in texture bfowser doesn't work for me.
  • hotkeys are buggered for me bad. some you fixed don't work now, or they will toggle the tool on but not of, i.e. hitting shift+a while the texture browser is open, it should then close it(it doesn't). Also, if your mouse pointer is over the 3d window when you toggle a tool, it will also move you the WASD direction as well!
  • hide mask doesn't work in texture properties
  • in source, hitting 'esc' key will deselect a brush and/or close a window, might be good to add.
  • no nudge
  • is there a way to toggle off the grey selctiong thingie over brushes? or at least adjust the opacity?
  • automatic selection now working for me
  • Alt-E scaling tool is missing? ='(
Sorry if some of these are doubles!

Btw, thank you for the improvements to texture properties! dem extra decimal places, and i love the fact that it updates automatically =)

Also love you can manipulate and adjust the clip blade in every 2d window... Great stuff man cant wait to see more :)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-07-31 13:11:23 UTC Post #314616
Long list CapT! Here we go:
  • Know of the used textures not working, it's in the list to be fixed.
  • I didn't know the tool selection hotkeys went back to the select tool if you pressed them a second time, I'll be sure to add it in. I know of the hotkeys not working when popup windows are open, fixing that is on the list as well. Are you having other issues with hotkeys too?
  • Hide mask is in the next build :)
  • I Know about the escape key not deselecting stuff, you should be able to use Shift+Q for now as an alternative while I try and fix it
  • Nudge is there, just turn it on in the settings! Or should it also nudge the box in the brush tool?
  • I will add the option to change the opacity of the grey selection thingie :P
  • Good!
  • Holy shit I have never seen that thing before. I'll investigate and see what I can do :P
Thanks for all your bug reports! Keep 'em coming! I keep track of all the bugs here if you're interested:
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-07-31 13:19:35 UTC Post #314617
i tried the settings for nudging but no joy. I was trying to nudge selected vertices.. Also i can't figure out what you mean by "nudge the box in the brush tool" =P

And ya, the hotkeys are all fucked =)

I do know some of these hotkeys we are requesting don't exist in hammer 3.x, so possibly could that be causing troubles?
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-07-31 13:28:15 UTC Post #314619
Oh, no nudging in the VM tool yet, I must have got distracted halfway though because it's almost done :P

By nudging the brush creation box, I mean when you have drawn a box to create a brush and haven't pressed enter yet, should the arrow keys also nudge that box around?

Can you go into a bit more detail about the hotkeys...? Do they just not work at all, or what?

Also, are you the one who's getting errors in the settings window all the time? If so, can you send me your FGDs? It seems that Sledge is failing to load one of them.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-07-31 21:18:56 UTC Post #314626
Yeah I realised I hadn't set up the WADs. I did, and it crashed on File > New again. So you should see the error report somewhere in your error report monitoring command room.

I only added the default WADs from the Steam install of HL.
Posted 7 years ago2013-07-31 23:09:14 UTC Post #314628
Ah yeah, that's caused by tempdecal.wad. If you remove it it should work. I've fixed that crash in the next build. I might as release the next build now, so I'll have an update soon :)

Edit: New release! This adds a bunch more options, fixes some bugs, implements some missing features. So a bit of everything!

Change list:
  • Check for invalid WAD lump types and don't load them. Fixes #34.
  • Implemented 'hide face mask' toggle
  • Implemented cordon render helper
  • Added option to render transparent tool brushes and hide null textures
  • Fixed an issue preventing decals and sprites from rendering in the 3D view. Fixes #29.
  • Added option to apply browsed texture immediately
  • Added option to customise the scroll wheel zoom multiplier. FIxes #36.
  • Turn on line smoothing for the center handles. Fixes #35.
  • Fix the 3D grid to render on untextured solids. Fixes #37.
  • Tool switching hotkeys should toggle between the hotkey tool and the selection tool. Fixes #39.
  • Escape key hotkey sequence was encoded incorrectly. Fixes #41.
  • Allow the selection box background opacity value to be changed. Fixes #42.
  • Implemented nudging for vertices in the VM tool.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-07-31 23:24:25 UTC Post #314629
You're really committing to it.
Posted 7 years ago2013-07-31 23:40:31 UTC Post #314630
Of course :D It helps that I happen to be on holiday this week so I don't have to waste valuable Sledge time at work :P
Let me know if you find any more bugs! Thanks for your help so far! :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 00:24:23 UTC Post #314631
Clicking the recent maps thing doesn't work for me. I had to find the map manually. Also, grids are not working for me still. (Radeon Gfx?) Show 2D grid is indeed toggled on. :/
Rimrook Rimrook❤💛💚💙💜
Posted 7 years ago2013-08-01 01:06:51 UTC Post #314632
Thanks Rim, it looks like both Ati and Intel graphics cards don't like the grids. I'm going to try and fix those on the weekend. I'll fix the recent maps for the next version :)

Edit: Oh good, my (long forgotten) laptop has a Radeon card and doesn't show the grids, so I don't have to borrow someone else's hardware for debugging. Hopefully that means I can identify and fix the grids problem soon! :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 02:04:35 UTC Post #314634
I like how you can select the source for the textures displayed in the texture browser.

There was something odd but I couldn't quite put my finger on it. Then I realised: Decals are shown coloured! I LIKE THIS.

Can't wait to see the grid. It gets pretty hard to get a reference otherwise.
Posted 7 years ago2013-08-01 05:17:02 UTC Post #314635
Haha, I can imagine - without the grid, it's pretty useless :P release! This should hopefully fix the missing grids. Stu and Rim, do you mind testing it out and letting me know how it goes?

Change list:
  • Fix EditFace crashing when faces are no longer in the map. Fixes #46.
  • Don't assume FGD choice keys are integers. Fixes #45.
  • Add hotkey support to forms that require it. Fixes #44.
  • Prevented the 3D view from moving around when hotkeys containing WASD are pressed. Fixes #40.
  • Fixed the recent maps menu not opening the map when clicked. Fixes #19.
  • All viewports zoom with the mouse wheel if control is pressed.
  • Fix the grid so it renders properly on certain graphics cards. Fixes #26.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 06:23:54 UTC Post #314636
What is the advantage you can get out of this programme the original doesn't have ?
Posted 7 years ago2013-08-01 06:56:19 UTC Post #314637
If you look back earlier in the thread, I answered the same question in detail in my third post. Basically - it has loads more features! Right now it's still unstable and missing some key features since this is an alpha version, but once those issues are cleared up it should be fairly good :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 07:01:48 UTC Post #314638
Going to fire it up now PB to check out the updates! =P

Malle: Besides improving all the old tools and functionality, Sledge is open source, so it can be constantly improved/upgrayedded by the community itself ;)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-01 07:02:55 UTC Post #314640
Who's mainly working on it?

i would like to see the code myself :)
Posted 7 years ago2013-08-01 07:28:10 UTC Post #314642
Just me right now, but anybody is welcome to make changes and submit pull requests at any time :)

The code is hosted on GitHub:
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 08:20:37 UTC Post #314643
You fixed the recent files opened as well most of the shortcut keys i've tested work properly now, nice! =)

Now though, Sledge is very crash happy for me. sometimes just clicking on the inside the 3d window is enough to crash it, and ther is no error message or bug report created, but i get this from windows:
Problem signature:
Problem Event Name: APPCRASH
Application Name: Sledge.Editor.exe
Application Version:
Application Timestamp: 51f9fbd8
Fault Module Name: StackHash_0a9e
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 0703f916
OS Version: 6.1.7600.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
Should i try a fresh install or anything?
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-01 09:08:50 UTC Post #314645
Nah, fresh install wont do any good. I'll see if I can find out what's doing it.
Edit: Yeah, I was able to crash it as well. Something in the graphics code, I will see what I can dig up.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 09:17:39 UTC Post #314647
I should also mention i'm running windows with NO UPDATES on this rig, so just letting you know in-case that's causing problems.

Also, adding/removing wads in my steam profile is causing issues, and keeps giving me the OOPS message =P
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-01 12:21:41 UTC Post #314648
I think that any problems you encounter will be because of the program, not Windows :P
Edit: New release! Should hopefully fix the crashing. That's the only change in this release :P Version number is

@CapT: Can you please try this new version and let me know? Also, can you send me your FGDs? Sledge thinks one of them is invalid and I need the FGD so I can debug the problem!
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 20:48:32 UTC Post #314649

Unlike before, it took a few seconds to "load" the new (empty) map. I figure it's something related to the grid. I don't care as longs as it works, it's a small performance detail.

I've noticed "Apply texture to all faces" is now in the texture application window as a modifier of the apply texture button. There's one detail though, and it's that it didn't apply a texture with right click AT ALL until I changed the list box to something else and back (set the left click action to "select" and then back to "lift and select" before right click worked).
Shift+nudging with arrow keys. In Hammer, it would duplicate the object once and then move the copy around until you release all the keys. Here, the object is duplicated for every unit it moves, for as long as you're holding them; you get a gazillion copies and it ends up looking like an extrusion.
3D view mouse look: If the texture application window happens to overlap it by just a bit, and you press Z and move the view in that direction, when the (invisible) cursor goes over that window control it is released from the 3D view and you have to press Z again. I know, just put the window far enough from the 3D view, but it's there.
Small suggestions:
On new map, remember the last configuration used and pre-select it. And an "OK" button for it might be handy as an alternative to double click.
On the texture application window, perhaps making the scale/shift/rotation controls move by a larger amount if right clicking the up/down buttons. Moving the scale setting by 0.25 or 0.5, shift by 8 or 16, and rotation by 5/10 degrees. Or make it configurable, I don't know. Just thought it could be useful.
I can't say it bothers me because I've always used the default layout, but I've noticed that the viewport type selection is not there (you know, where you select 3D textured, 3D flat, 3D wireframe, etc.) Was this intentionally dropped or is it just not done yet?
Does/will this run on linux? Because that would be killer.
non development-specific question: I'm too lazy to turn on my old computer and find it there; where is the HL1 FGD in a Steam installation? Because I can't find it.
Posted 7 years ago2013-08-01 21:45:48 UTC Post #314652
You know what'd be cool? Mapping in some sort of Virtual Reality machine. Imagine like, standing around in your creation, resizing brushes with your movements, etc... That's the next step for Sledge, right?... Right?
Jessie JessieTrans Rights <3
Posted 7 years ago2013-08-01 21:55:43 UTC Post #314654
You mean integration with Oculus Rift? I'm all for it.
Posted 7 years ago2013-08-01 22:12:22 UTC Post #314655
I'm getting my Oculus Rift this month. If Source SDK has support for it, I might be inspired to make a few projects built for it.
Dimbeak DimbeakRotten Bastard
Posted 7 years ago2013-08-01 22:16:06 UTC Post #314656
Hooray Stu, the grid is finally working :P

For your bugs/suggestions/questions:
Yeah, there seems to be some bugs in the texture window. I'll have to do some proper testing on it to work out all the issues.
Check again :) Hammer 3 doesn't do any shift+nudge cloning, and Hammer 4 makes lots of copies if you hold it down. It should probably be an option anyway.
Not a lot I can do about the 3D mouselook thing. I tried a bunch of different behaviours and that was the best I could get. I might take another look at it, though.
Yeah, the config select window bothers me. It'll definitely get revamped at some point.
I could make the texture number boxes configurable, sounds like a good idea.
Viewport type selection is not done yet, but I plan to add it at some point. It's a pretty big change so I've been avoiding it :P
Linux support - maybe in the future. I hear Mono is reasonably good these days, however right now I'm focusing on just getting the program working properly on Windows :P
I don't think the steam install includes the FGDs, you'll need to redownload them.
As for virtual reality support...the code is open! Feel free to add VR to Sledge, I wont turn it down! :P
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-01 23:10:57 UTC Post #314657
Check again :) Hammer 3 doesn't do any shift+nudge cloning, and Hammer 4 makes lots of copies if you hold it down. It should probably be an option anyway.
Ow, sorry. I was pretty sure I remembered doing that, but now that you say this, it might have been using something else... probably Corel Draw. I didn't check because I don't have Hammer on this computer.

But yeah, it would probably be the desired behaviour if it made one copy only and moved that copy until you released all the keys. Surely nobody wants a million copies of the same object separated 1 unit each.
Posted 7 years ago2013-08-02 06:23:18 UTC Post #314661
i would like to see some stuff from blender 3d and 3dmax, like extruding and more :o
Posted 7 years ago2013-08-02 10:10:51 UTC Post #314667
Big improvement from the last version PB!

I've been editing for about 45 minutes with no major issues! I'm working on rebuilding this, as a primer to explore Sledge =)

  • clip tool: clip tool hotkey is an exception to the rule, and Shift+X should cycle through the clip sides, NOT toggle the tool off ;)
  • clip tool: will not let me clip complex objects fsr(may be related to the above, or the fact i was dealing with a decompiled map)
  • Mark textures feature(reminder)
  • Alt+E scaling not implemented(reminder)
  • tool mouseover should also list their respective hotkey, not just the name
  • Ctrl+M scale requires nonzero values for xyz, even if you are only scaling one dimension(maybe change the default values from 0.00 to 1.00 to avoid this)
  • automatic selection should also work for verticies using VM
  • possibly reduce some of the clutter on the top bar for things that are(and should) be done with hotkeys, e.g., undo/redo, compile, etc.(by contrast, the left tool pane is nice perfect)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-02 10:48:43 UTC Post #314668
Cool that it hasn't crashed on you so far CapT :P Good luck!

I'm taking a break from bug fixes to work on major features now (revamped VM tool, automatic configuration, multiple open files, model rendering) so updates will be less frequent. Keep reporting bugs though, they won't be forgotten :)

For the toolbar clutter: eventually it will all be customisable. You will be able to configure what toolbar buttons you see, and change all the hotkeys as well.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-02 17:04:41 UTC Post #314672
Gonna try this when this will be more stable and will have the models. :)

Wait what? An autosave function? Hammer (Goldsource) didn'r have that. Or maybe source did.
Posted 7 years ago2013-08-07 23:49:20 UTC Post #314771
Support bigger maps you say? How much bigger? Sounds really cool so far i'll have to check it out.
Posted 7 years ago2013-08-08 00:10:33 UTC Post #314772
@Zeeba: It should support map dimensions of about 79228162514264337593543950335 units. However it's probably not a good idea to try values that large. I would keep it at 16384 which I believe is the dimensions for the VHLT compilation tools and the hacked 'big map' version of Hammer. To change map dimensions, take a look at the base.fgd from the Source SDK, and use the map size attributes from that to specify whatever dimensions you want. (I haven't actually tested this but it should work >_>)

@All: I'm slowly working on a revamped VM tool, which I should have finished in the next few days. It fixes the missing features (scaling tool), hotkeys (ctrl+F), and selections (in the 2D and 3D views) that are present in Hammer, plus adds some new features and functionality that should be useful (bevel, poke face, real-time "invalid solid" error list, etc). After that I'll start on the other features that alpha is missing :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-08 02:13:46 UTC Post #314774
Sounds amazing PB, can't wait to try the new features!
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-08 02:20:35 UTC Post #314775
I'm guessing a map spanning 79228162514264337593543950335x79228162514264337593543950335x79228162514264337593543950335 would most likely fit Half Life from beginning to end without a map change several times over.

It would still hit the entity limit pretty fast, though.
Posted 7 years ago2013-08-08 02:36:11 UTC Post #314776
That'd be getting close (in terms of 1x1x1 squares) to the estimated number of atoms in the universe.
Jessie JessieTrans Rights <3
Posted 7 years ago2013-08-08 03:01:24 UTC Post #314777
Close to the estimated number of atoms in this universe you mean ;)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-08-08 03:14:29 UTC Post #314778
I'll take your word for it, I have no intents of counting them.
Posted 7 years ago2013-08-08 23:39:28 UTC Post #314795
I've downloaded it, but have had no opportunity to test it as of yet so I don't know if this bug is present. In Hammer if you had the entity properties window open and you changed any values, then switched to the flags tab it would reset those values you changed. I had to change the values, close the window then reopen it if I wanted to edit the flags.
Alabastor_Twob Alabastor_Twobformerly TJB
Posted 7 years ago2013-08-09 00:46:00 UTC Post #314796
@TJB: Nope, that bug wouldn't be there. You need to click "Apply" or "OK" to save any changes you make though. If you close the properties without saving, it won't apply them. Just changing tabs won't reset anything though.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-09 18:06:55 UTC Post #314811
Dude editing hammer's code is the most brilliant idea ever. I know nothing about code but what code does it use? :glad:
Posted 7 years ago2013-08-09 18:45:31 UTC Post #314816
Source code, obviously.
Posted 7 years ago2013-08-10 00:46:31 UTC Post #314818
zeeba: Sledge is his own code, from scratch. C#, I think.
Notewell NotewellCall 141.12
Posted 7 years ago2013-08-10 01:05:24 UTC Post #314819
Yep, C#, and it's not a Hammer mod, it's made completely from scratch. All the source is available on GitHub.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-10 17:56:26 UTC Post #314831
I recently submitted an error report. It appears that ViewportBase::OnResize is called in one of Viewport3D's base class constructors, when Viewport3D::Camera is still null.

This error does not occur when Window's DPI (GUI scale) setting is 100%. It does occur when it's 125%.
Oskar Potatis Oskar PotatisIt's never too late to give up. Happily lazy
Posted 7 years ago2013-08-10 23:42:04 UTC Post #314834
New release!

This version adds a revamped version of the VM tool. I wasn't happy with the scaling tool hiding behind a hotkey, and I wanted to be able to add additional functionality to it in a way that was easy to see from a user's perspective without having to know all the hotkeys from the start.

Fixes missing features from Hammer:
  • Split face (Ctrl+F), Scaling tool (Alt+E)
  • Auto-selection in VM tool
  • Click-to-select solids in 2D and 3D in VM tool
New features include:
  • Switch between standard mode (Alt+W), scaling mode (Alt+E), and face edit mode (Alt+R)
  • Real-time VM error list
  • 'Reset to original' button
  • Face edit mode: lets you poke a face (add a point in the middle) and add a bevel to a face.
It looks like this:
User posted image
Let me know what you think! I know it's different to how Hammer does it, but I think having the dialog there is important considering that the VM tool is one of the more advanced features in both Hammer and Sledge.

Change list for this version:
  • Added revamped VM tool. Fixes #43, fixes #25.
  • Select automatically in the VM tool. Fixes #49.
  • Show hotkey name in tooltip text for the main toolbar
  • The manual tranform dialog switches to default values of 1 when scale mode is selected.
  • Case insensitive format providers. Fixes #50.
  • Null camera check on SetViewport. fixes #51.
  • Check the compile tools are set up before compiling.
  • Check for no entries before setting the Steam username selected index.
@potatis: Great catch, I never would have thought to increase the Windows setting to replicate that bug. Fixed it in this release (it was issue #51) :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-08-11 10:51:10 UTC Post #314836
You don't have a logo yet do you?
Just thought of a modernised version of the existing hammer logo. It's so hard to try not to type "Sledge Hammer" as well.
User posted image
Also may I suggest updating the colour scheme of the UI to something more like the new version of photoshop? Makes it look more ~artistic~.
User posted image
Instant Mix Instant MixTitle commitment issues
Posted 7 years ago2013-08-11 11:28:02 UTC Post #314837
I suggested a logo before, but it looks more like Sredge :P
User posted image
I agree for the GUI, an photoshop like GUI would be sick.
Stojke StojkeUnReal
You must be logged in to post a response.