Sledge (Hammer Alternative) Alpha Build Created 5 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Created 5 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Posted 3 years ago2015-02-10 02:59:11 UTC Post #323862
Geometrically speaking, a plane can never be invalid with 3 vertices.
Posted 3 years ago2015-02-10 03:34:30 UTC Post #323863
Penguinboy, if those columns of yours would be all cut diagonally (made of triangles) and skew lock worked well then you would be able to distort it the way you pictured it, in quite a shaggy way though, there would be a huge distortion on the line where triangles join, however the pixels would indeed be seamless and if wisely divided into triangles it could work quite well, probably for organic textures the most, I think I've seen this on many older games. Might be good enough to make truly seamless curved water flow and stuff like that
Posted 3 years ago2015-02-11 02:23:30 UTC Post #323908
I was getting invalid solid errors from CSG (but not Sledge's error detector) because I'm a bit rusty at GS. I think I figured out a fix, but when I went to clip the solid responsible into two so it would be valid...
User posted image
:(

I'm also getting a lot of errors where clipping a brush will reverse the normals on it, so all the faces render inside out. Not sure yet if that causes it to be an invalid solid as well, or if it's just a rendering issue in Sledge.

EDIT: And I just encountered a crash when coming out of sleep mode with Sledge open.
Windows 7 64-bit, if that helps.
JeffMOD JeffMODCall 141.12
Posted 3 years ago2015-02-16 05:13:24 UTC Post #324156
Hey PB, I was running a compile with sledge when my computer crashed.
It won't start now.
I see sledge in my processes but the window doesn't show up.
I have uninstalled and re-installed.
I have repaired my .net framework install as well.

ever see anything like this?
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-16 05:37:20 UTC Post #324157
I'm also getting a lot of errors where clipping a brush will reverse the normals on it, so all the faces render inside out.
I've had this happen several times when clipping very simple brushes.
potatis_invalid potatis_invalidh̲͚̤̿͑̔̒̃̉̓ȋ͂͋̉̿̎͋̈́͏͚͖͇̭̩͓͔͝
Posted 3 years ago2015-02-16 06:23:09 UTC Post #324158
Never seen that before, Tet. Maybe there's something wrong with one of the open maps? Try deleting the "session" file in the "%AppData%\Sledge" folder (this is the list of files to re-open on startup). If that still doesn't work, try deleting the "Settings.vdf" file (this is all the game configs/settings, so maybe back it up first).
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-02-16 19:47:18 UTC Post #324185
Sledge has been crashing for me as well. Besides that it's so awesome! surface and object selection is pinpoint compared to hammer on a laptop. And I love viewing transparencies within the editor.

I might recommend a selection method similar to most modeling and drafting programs. If you scroll drag select from the right to left, it has a broken line on the selection box and selects anything that intersects inside it. If you drag select from the left to right it has a solid line and only selects anything that is completely encompassed within the selection window. Extremely useful stuff. I have no idea how hard something like this would be to implement though.

Like someone who has never mapped in goldsource sitting down and telling me to map a few spheres and a door that rotates diagonally :0

Sorry if this has been already brought up, I only read a few pages of this thread.

Also a drag selection in 3d window paired up with the stuff above would be nice for selecting multiple vertices in vm.
Posted 3 years ago2015-02-16 23:05:08 UTC Post #324189
Penguinboy, that did the trick.
seems my Settings.vdf was corrupt.
I'll have to re-configure :( but at least i'm up and running now
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-17 00:21:54 UTC Post #324191
@Zeeba: tbh, I think that implementation is quite obtuse in terms of usability. If you didn't already know, if you hold down shift, only items that are fully enclosed in the selection box will be selected. AFAIK, Hammer does it the same way.
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-02-17 02:12:43 UTC Post #324193
Doesn't seem to work in hammer, but awesome if it's in sledge that's perfect!
Posted 3 years ago2015-02-17 16:04:46 UTC Post #324216
If you scroll drag select from the right to left...
Do you mean "Paint Selection"? That would be useful to select faces a lot faster (it's annoying sometimes to select every single face with one click).

@PB: kHED has the same feature (paint selection). You just have to press and hold "Shift", click and hold the left mouse button, and move the cursor over the faces to select them as the cursor touches them (this in the 3D view).
It'd be a great time saver imho. :3

Also, would it be possible to add a full screen support with [Alt]+[Enter]? Or anyway with another hotkey ([Alt]+[Enter] is the classic one, like on DOSBox or other applications, it doesn't really matters). It'd be good to be able to have a real full screen preview. :)
On a side note, I already know about the "F5" key that makes your 3D view enlarged to the maximum limit (though not being "full" actually).

Another thing that came to my mind a few days ago, is if we could be able to choose the Primitive/Brush Type's direction (Top x/y, Front y/z, Side x/z).
For instance: if I want to create an Arch brush type, I can see it in its top side in the Top view only, while in the others I just can see the other sides. But if I want to have the Arch's top side directed to the Front y/z side, I'm forced to rotate the arch AFTER its creation, and this is a bit frustrating if I have to make measurements by using the preview feature provided with the awesome Sledge. Indeed, to do that, I need to copy those brushes where the arch should fit, rotate them, and make them facing the actual view to do this.
So, it would be better (and handy at the same time) to have an additional drop-down menu in each Primitive/Brush Type where we can select in which of the three 2D views we want the brush to be directed.

I hope it's clear enough. Sorry for my embarassing english. :nervous:
Alberto309 Alberto309weapon_spaghetti
Posted 3 years ago2015-02-17 22:14:17 UTC Post #324228
Penguinboy, deleting entities from the entity list, and then trying to save or activate the 3D view crashes Sledge.
If you cannot recreate this, i have a map that will do it everytime.
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-18 14:13:01 UTC Post #324235
@Tet: are they specific types of entities?
Alberto309 Alberto309weapon_spaghetti
Posted 3 years ago2015-02-18 22:32:38 UTC Post #324244
Specifically it was a 0x0x0 unit func_water located at the origin.
So possibly it's deleting invalid entities.
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-19 00:35:26 UTC Post #324247
Yea I had deleted parts of it with clip right on the lines where two brushes met. So that could be why it did it.
Posted 3 years ago2015-02-20 04:38:04 UTC Post #324254
@Tet: Aww, yeah it could be that. I've experienced something like that, but only PB managed to fix it by editing my RMF somehow. :(
I hope it's not the same problem.
Alberto309 Alberto309weapon_spaghetti
Posted 3 years ago2015-02-20 08:26:40 UTC Post #324259
I had an odd effect not long ago. Had a brush entity which I hid (via "hide selected"). After I'd closed and reopened Sledge later, I couldn't seem to unhide it. I'd had some things like this before where messing with the visgroups could get it to show again, but that didn't work in this case. It was still in the entity list, and when I hit "Go to" (which I'm pretty sure stuck me at origin), when I tried to move the 3D view, it immolated me with error messages. I ended up deleting the entity and recreated it.

tl;dr: I think hiding things and restarting Sledge can cause odd effects with the hidden objects.
Jessie JessieLadytype
Posted 3 years ago2015-02-20 12:17:06 UTC Post #324262
I've had a few issues with sledge recently that I'd not noticed before which has made me resort to using hammer for geometry and then Sledge for everything else..

basically, whenever I shift-drag an object, even if texture lock is on, the texture alignment screws up completely. No idea why this happens.

Noticed as well that if I use ctrl & M to open up the transform window, I have to physically click on "ok" rather than press enter, which is quite frustrating if i'm having to rotate a bunch of objects

Also, I can't figure out how on earth to replicate Hammer's alt-click texture feature, nothing I can see on the drop down list does it on the texture application window.
Instant Mix Instant MixTitle commitment issues
Posted 3 years ago2015-02-20 15:46:41 UTC Post #324271
basically, whenever I shift-drag an object, even if texture lock is on, the texture alignment screws up completely. No idea why this happens.
I have ran into this too. I get around it with a quick CTRL+C & CTRL+V and drag the new copy. Not as efficient but it works.
Also, I can't figure out how on earth to replicate Hammer's alt-click texture feature, nothing I can see on the drop down list does it on the texture application window.
Yeah it doesn't seem to work the same way. Definitely something that needs to be looked at because Hammer's ALT+Right-Click is the best thing since sliced bread.
Another note.
deleting entities from the entity list, and then trying to save or activate the 3D view crashes Sledge
I've noticed that deleting a 0x0x0 entity/brush from the Problems Prompt turns your 3D window black. If you save or try to move around in the 3D window you get pelted with Warnings. HOWEVER, dragging out a new camera (shift-drag with camera selected) in a 2D view creates a new camera and re-activates 3D view / Saving capabilities without crashing Sledge.
TL;DR: I think the camera somehow gets deleted when removing those crazed glitch entities.
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-20 20:25:15 UTC Post #324272
I think Tet and I might be describing the same effect with the camera.
Questions for PB on this: Given how it looks on the 2D views, is the camera information stored and used as a set of two different points, one for the camera's location and the other for where it is looking? If so, how does Sledge cope when these points are precisely the same?

EDIT: WHOO BOY, I think I just confirmed my suspicions. Opened new map, dragged camera direction pointer onto the camera itself, tried to move 3D camera... "Something went horribly wrong" alright. EDIT2: Tried to use WASD rather than the mouse to see if the effect changed. And it did. The error messages literally didn't stop coming :pwned:

I think whatever Tet and I are doing, it's resetting the camera to origin, both points, which messes things up.

Just to highlight, for Pengy's convenience:
Sledge cannot handle movement in the 3D view when the camera and its direction pointer are at the same point
Jessie JessieLadytype
Posted 3 years ago2015-02-20 20:26:44 UTC Post #324273
Yeah Good observations Jessie. PB, Check the camera information when you 'Go to Problem brush' from the check for problem tab.
That might be the culprit?
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-02-25 10:09:33 UTC Post #324399
I have no idea how to set this thing up. My textures aren't appearing when I try to search for them?
Posted 3 years ago2015-02-25 10:26:28 UTC Post #324400
It should auto-load WAD textures as long as you set up your game folders, here's an example (set up your steam directory in the Steam tab first):
User posted image
If you want to map for Source, it's not supported yet.

Edit: example for WON installs, you can also do this if you have a custom steam library folder instead of the default:
User posted image
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-02-25 11:04:47 UTC Post #324404
I'm making a map for TF2, I have no idea what engine it uses though. Can sledge make tf2 maps? If so, what directories should I put in there?
Posted 3 years ago2015-02-25 11:06:31 UTC Post #324405
TF2 is Source engine which is not supported yet, sorry. You'll need to stick with Hammer for now until it's supported in Sledge.
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-02-25 11:09:25 UTC Post #324406
:( Okay then, Sledge seemed pretty cool though, guess I'll wait for them to support source then
Posted 3 years ago2015-02-25 14:28:46 UTC Post #324409
Sledge functions very much like Hammer, with a few improvements.
There's nothing stopping you from mapping for TF2, once you get Hammer, everything is set up automatically for you.
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-03-13 17:56:12 UTC Post #324669
I just had a bit of a weird error. I was VMing, and when I merged two pairs of vertices the crash window popped up. I sent the report, but Sledge didn't close itself. I clicked on one of the vertices again and another error window popped up, however the vertex was still following my cursor. Each time I clicked it would open a new error window.
I took a screenshot, but it was only after closing Sledge with the task manager that I realised it was only a shot of the error window itself.

[Edit]
Also, a feature request. How about having a preview button for sounds? Like when you select the move and stop sounds for doors and stuff.
Posted 3 years ago2015-03-28 15:48:02 UTC Post #325067
Brush Tool
add-on request

When selected/hotkeyed, add an option that rolling the mousewheel cycles through the various
Brush Tool
templates. or you could make it shift+mousewheel as to not interfere with zooming

Solid-with-#-of-sides bug
When I select a brush, Sledge no longer tells me how many sides it has? Has it never/ever done this? Maybe I'm thinking of the CSGO SDK
Captain Terror Captain Terrorwhen a man loves a woman
Posted 3 years ago2015-03-30 00:18:27 UTC Post #325119
@Penguinboy: Really quite serious issue.

I don't know whether this is a known issue or not, but it's really shitting me off, quite frankly. I wasn't sure exactly what was going on the first couple times, but now that it seems to have basically deleted a good half of my TWHL Tower map, I figured I should probably investigate. As far as I can tell, this is a problem and I'm not just doing something stupid, but feel free to prove me wrong.

Brushes that are tied to an entity, if hidden, do not seem to be saved.

Here's my fun demonstration that you can try at home!
I created three blocks. The one on the left was left alone (the control), the middle one was added to a visgroup called "visible" and the one on the right to a visgroup called "invisible". I then shift-cloned all three down (shift-cloning maintains the visgroup properties) and then tied each new block to an entity.
User posted image
I then unticked the "invisible" visgroup, hiding those blocks. Then I saved, and exited Sledge. Upon reopening, and showing the "invisible" visgroup again...
User posted image
As you can see, the hidden entity brush is now gone. The entity still exists but is empty, hence the "func_detail" floating at origin. Alt+P verifies this.
Other small tests I've just done show that this does not happen to point entities, using the "hide selected/unselected" buttons has similar effects, and if multiple brushes are part of an entity and not all are hidden, the visible brushes will not be affected.
Jessie JessieLadytype
Posted 3 years ago2015-03-30 00:36:20 UTC Post #325122
It's not deleted, open the map and save it as an RMF instead. It's a known issue with VMF and visgroups. Just use RMF for the time being.
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-03-30 01:19:30 UTC Post #325123
Did so. They still seem noticeably absent.
Jessie JessieLadytype
Posted 3 years ago2015-03-30 04:02:02 UTC Post #325126
Yep, I just tried it, looks like you're right - the solid is entirely gone. I think know why though - and if you have the VMF (or an autosave) from immediately after you saved it (and didn't open and re-save), I can tell you how to recover the lost solids. Otherwise, the solution is still to use RMF instead, it's very much a problem in the VMF loader. Load up an autosave or a backup from before the brushwork disappeared, save as an RMF, and you'll be able to carry on.
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-04-03 00:57:29 UTC Post #325193
Attempted to convert an unfinished CS:GO map to 1.6 using Sledge just to see if that would work. Did all the obvious stuff like removing all Source entities and all that.

Got about 3 versions of the "Brush Outside World" error with it listing a brush as being at over -80000 on the z plane. I've tried using the cordon tools and also looking for any broken brushes but no luck so far.

Is there a known solution to this kind of issue or is it just not possible to convert vmf to rmf at this moment?
Posted 3 years ago2015-04-05 23:48:18 UTC Post #325206
Possibly you can isolate the culprit brush(es) causing that error, by using the big-block method for locating leaks?

If all else fails you could use the original brushwork as a template and rebuild everything, though I know this is not the solution you're looking for ;)

I can try converting for you if you if you like.
Captain Terror Captain Terrorwhen a man loves a woman
Posted 3 years ago2015-05-09 13:42:58 UTC Post #325498
Does Sledge have any way of controlling the speed of the camera for when you're moving it around? If not, could I request one? It's just sometimes when you're doing small, precise things, it can be a right royal pain to get a camera is exactly the right spot. IMO.
Jessie JessieLadytype
Posted 3 years ago2015-05-09 15:04:24 UTC Post #325500
User posted image
Captain Terror Captain Terrorwhen a man loves a woman
Posted 3 years ago2015-05-09 15:14:27 UTC Post #325501
Ah, dankeschön! Not... sure how I managed to not find that! :quizzical:
Jessie JessieLadytype
Posted 3 years ago2015-06-01 17:45:38 UTC Post #325760
Just thinking aloud:

Do you reckon it'd be feasible to have a brush primitive that works in the same way as the Text Primitive, but for path information from vector graphics? Would allow for logos and such to be very quickly created in brushwork.
Archie ArchieGoodbye Moonmen
Posted 3 years ago2015-06-06 17:50:55 UTC Post #325826
So I mentioned the texture alignment bug I have earlier. Well, recently I was playing around with Sledge and I found out that some stock textures (halflife.wad) have the same problem! Just FYI.
Posted 3 years ago2015-06-06 20:14:14 UTC Post #325827
Are you sure texture locking isn't off?
Posted 3 years ago2015-06-06 22:16:52 UTC Post #325828
As I demonstrated before (see my posts on this page: http://twhl.info/forums.php?thread=18410&page=25), the problem has to do with decimal rounding during compiles.

I thought it was because of some large-ish custom textures that had to be scaled down, and the rounding of the XY scale caused the offset to be out of whack. I just noticed it was also happening with stock textures that weren't scaled down as much.

My fix suggestion was to limit the texture fit and center buttons to two decimal precision since that's what Sledge outputs to the compiler, but I dunno if that ever got added to the bug database.
Posted 3 years ago2015-06-07 03:29:06 UTC Post #325829
I don't know for sure, but I think Penguinboy might be a little burnt out with updates, and/or is working on sorting other problems.

I THINK I did notice some new things fixed the last time I used Sledge recently, but not entirely sure when the last version was released. Keep in mind PB logs all bug reports and feature requests, even if they aren't immediately addressed.
Captain Terror Captain Terrorwhen a man loves a woman
Posted 3 years ago2015-06-07 06:43:35 UTC Post #325830
Yeah, he said it was something it might take him a while to get around to.
Posted 3 years ago2015-06-10 17:58:35 UTC Post #325877
For some reason, the steam configuration doesn't work.

I think its because of the changes in the directory, where all the games from [username] gone to common folder. So now I can't do the steam config.

But does the special steam config affect the editing, or is it ok to use the normal config?
Posted 3 years ago2015-06-10 18:17:53 UTC Post #325878
You can just map everything to the proper folders manually.
That's how I have it working.
Tetsu0 Tetsu0Original Cowboy
Posted 3 years ago2015-06-13 13:04:36 UTC Post #325928
Ok and another bad thing:

Anytime I try to move the blueprint, I always deselect. Really anoying when you are trying to do something very fine with huge things.

Maybe there is an option where you add the sliders back? They really help out. At least for me.
Posted 3 years ago2015-06-13 13:20:14 UTC Post #325929
Do you mean the 2D grid view? You can middle click + drag to shift it easily, but I usually just zoom out and back into the spot I want to move to. You can also change the settings so that the arrow keys will scroll the 2D views as well (instead of nudging the selection). Scrollbars are unlikely.
Penguinboy PenguinboyHaha, I died again!
Posted 3 years ago2015-06-13 17:17:07 UTC Post #325937
Also Space + left mouse allows you to move the 2D view around, which is exactly how Hammer does it.
Posted 3 years ago2015-06-13 20:24:33 UTC Post #325938
^ Space + left-mouse dragging is the way I've always done it, but it's good to know about dems middle clicking! (which is even easier) :)
Captain Terror Captain Terrorwhen a man loves a woman
You must be logged in to post a response.