Sledge (Hammer Alternative) Alpha Build Created 7 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Created 7 years ago2013-07-27 02:24:39 UTC by Penguinboy Penguinboy

Posted 7 years ago2013-09-03 21:20:34 UTC Post #315452
Yeah i know, but this makes it much simpler and i think its a nice addon for sharing RMF data :)
Stojke StojkeUnReal
Posted 7 years ago2013-09-03 21:25:31 UTC Post #315453
PB are adding the coop mapping down the road, maybe it would kinda tie into that =)
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-04 15:28:34 UTC Post #315475
@Captain Terror:
Whaaat? D: Really?? OMG! I wanna use Sleeeeedge! :(
Pleeease make it work on my pc, B0$$! xD
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-05 19:37:02 UTC Post #315511
It doesn't exist. I've not seen it anywhere and the closest thing to it is a well made help file.
Blender has a search-for-tools feature afaik. Could be a neat addition to Sledge.
Daubster DaubsterVault Dweller
Posted 7 years ago2013-09-08 23:52:55 UTC Post #315562
Great news! I figured out why I couldn't use Sledge anymore. Turns out Sledge was using my integrated Intel HD Graphics instead of my nVidia card. So I simply changed what program it uses in the nVidia control panel! No more crashing!
Posted 7 years ago2013-09-09 00:12:15 UTC Post #315563
Cool, glad that wasn't a big issue :)

I'm sorry for the lack of updates everyone, I'm still burned out on programming so I don't have the motivation to work on it at the moment. I might upload an unofficial build with a few fixes and so that Alberto can test the new rendering engine. I'll let you all know when I'm back working on new Sledge features :)

@Stojke: That will probably fit in nicely with the prefab support that will be added at some point.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-11 09:39:54 UTC Post #315619
New version! Sledge finally has a logo! (thanks to Instant Mix for the design & others for colour suggestions)
This version also introduces some additional rendering options for folks who are not fortunate enough to have OpenGL 3.0 compatible graphics cards.

Rendering options:
User posted image
Desktop icon (F5 your desktop after updating to get it to appear):
User posted image
Proper about screen:
User posted image
Full change list:
  • Two new OpenGL 1.0 renderers, hopefully they work on older hardware.
  • Added some new icons & logo
  • Changed some windows to open in the center of the screen.
  • Fixed the texture tool not highlighting correctly when a face is selected
  • Fixed the texture tool not applying the selected texture when a face is right clicked
  • Changed the entity editor to not intercept hotkeys. Fixes #60.
  • Stop the 'Hide unselected' feature from hiding the worldspawn. Fixes #65.
  • Add numeric zoom hotkeys to 2D views. Fixes #71.
  • Fix loading of dependant FGDs. Fixes #72.
Looking forward to hearing how the new renderers work on older hardware :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-11 19:15:36 UTC Post #315640
Double post! Bad Penguinboy :P

Question about the rendering options: What does that mean to those of us with limited graphics hardware? Besides just trying out every option to see which one works.

Hey look... I think now we know Penguinboy's secret identity.

Posted 7 years ago2013-09-11 21:40:53 UTC Post #315643
The OpenGL 3 renderer is faster and has better support for transparency. The OpenGL 1 renderers are slower and don't support the 3D grid.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-11 22:15:03 UTC Post #315644
I thought that was because OpenGL3 wouldn't run on my hardware or whatever happened to the grid earlier. It works just like before, so I'm not sure this affects me at all.
User posted image
Above labels cut off (lack of space?)
Settings window is still not centered on screen.
Wasn't there a "sync scrolling across 2D views" option?
Will keep looking.
Posted 7 years ago2013-09-11 23:58:12 UTC Post #315646
The issue you were having before with the 3D grid was an unrelated bug and was fixed in another version. The "sync scrolling across 2D views" should happen if you hold control while mouse-wheeling.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-13 13:50:49 UTC Post #315689
Yeah! Nice one PB!

I'm gonna try it out as soon as possible, and then I'll give you all the necessary feedback! ;)

Thanks again!
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-14 11:18:01 UTC Post #315693
Yes Finally a logo and it looks great! I love the colours, my only bicker is i feel it should have a longer handle and smaller mallet, like a traditional sledgehammer.

Booting up Sledge now to check the changes =)

Seems you fixed most-all of the texture bugs, and the only inconsistency i can see with normal hammer is the aforementioned find/replace bug when missing textures are concerned.

I love how you can make changes so quickly(seemingly like magic since i'm not a coder), well done!

Sledge is really shaping up fast :P
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-14 12:03:21 UTC Post #315694
Has anyone suggested the feature of being able to create plugins for Sledge?
I'm thinking something like Photoshop actions, designing plugins which do special things that would otherwise require lots of time.
(example: designing doors with multiple parts that sync)
Striker StrikerI forgot to check the oil pressure
Posted 7 years ago2013-09-14 12:16:47 UTC Post #315695
Has anyone suggested the feature of being able to create plugins for Sledge?
Idk, read the first page maybe? =P
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-14 12:26:57 UTC Post #315696
Striker StrikerI forgot to check the oil pressure
Posted 7 years ago2013-09-14 12:35:28 UTC Post #315697
Plugin support will be added in the future, but that's still a long way off :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-14 13:16:12 UTC Post #315698

But seriously hurry up. Sledge isn't going to godamned make itself get busy mister =P
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-14 13:20:02 UTC Post #315699
Ah, cheers for using my icon :L Just incase you edited the one I linked to on twhl, here's the actual full logo
User posted image
And with Alpha
User posted image
Instant Mix Instant MixTitle commitment issues
Posted 7 years ago2013-09-14 13:28:12 UTC Post #315700
hmm make the sledge icon looks simillar to yours twhl avatar...
Posted 7 years ago2013-09-14 13:43:07 UTC Post #315701
Thanks for making the logo, Instant! I actually had Strider vectorise it so I could make super large versions if I needed to. For example, here's a 2048x2048 version of it :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-14 14:30:51 UTC Post #315702
Sledge Banner for linking, or is it too early?
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-14 16:05:17 UTC Post #315704
Ok so, I tested Sledge. Good news! It works if I select the middle OGL 1.0 option. But I got some strange issues like:
  • No Transparent textures support (I see them white so I can't see its position);
  • For almost every texture I apply to a face, the more I move back to them the more I see a strange view of the texture with a bit of transparency (I actually can see the solids edges like when you are looking at your map in game with gl_wireframe 2);
  • There's no CTRL+H shortcut (Make hollow). I have to test other shortcuts;
  • Adding a "X" to close the textures tab would be better imho;
  • "Light" entities aren't selectable and I can't see them in any of the 4 views. If I select the area where the light entities are and deselect the other non light entities I'm able to move it just by using arrows (the entity is selected in a way where I can't click it in the middle but just on the corner edges, like when you make a blank selection of 0 units);
  • Compiling a simple map with a classic box with a light (and a light spot) and a player start results in a completely black map like I'm looking at the void and no lights.
  • No compiling options: When I click "Run" it goes directly with the compiling process without opening the classic window to set the compiling options. The Sledge options/settings are the same I showed you some time ago for the only exception of the OGL option thet I changed to make it run;
  • Open that same .RMF (box with light etc...) with Hammer, make it pop out the "Out of memory" error message.
That's all for now. I'll provide you with some screenshots/videoclips later, so you can better see by yourself the errors I'm encountering.
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-14 20:33:01 UTC Post #315706
What's this someone said about Sledge being able to open vmfs? It crashes instantly if I try...
Archie ArchieGoodbye Moonmen
Posted 7 years ago2013-09-14 20:50:14 UTC Post #315707
Noone said it was able with a 100% chance of success.
Posted 7 years ago2013-09-14 22:06:25 UTC Post #315708
But is there something i need to do? the map is just brushwork, no displacements or ents & only nodraw.
Archie ArchieGoodbye Moonmen
Posted 7 years ago2013-09-14 22:11:28 UTC Post #315709
I can edit vmf fine...

Ok so i'm editing a map and then the error dialog starts cascading like when you win at Solitaire:

User posted image

..and it keeps going and going and going =P

I've messed with existing vmf before with no crash, maybe it depends on the map?
Captain Terror Captain Terrorwhen a man loves a woman
Posted 7 years ago2013-09-14 22:31:00 UTC Post #315710
@Archie: Are you able to send me a VMF that crashes when you open it? I have opened several of the VMF's provided by the Source SDK (TF2 maps, etc) without crashing so I'd be interested to know what's causing it :)

Edit: Also, what FGD setup are you currently running? It might be that causing the problem rather than the map you're trying to open.

@Alberto: Does that 'out of memory' error happen every time you try to open that one map, or is it random? Can you also show some screenshots of the transparency issues?
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-15 04:58:06 UTC Post #315711
Mhh, not sure of this, I've tried to open it only once. Tomorrow I'll make more testings. I'll provide you all the necessary files, even the .RMF if you want to test it by yourself. This afternoon you probably got an update from me. :)
Yeah, Sledge can open VMFs! :D I've opened a my CS:GO WiP map with Sledge, it reads pretty much everything, even displacements, but... infinite? :o Like when you're trying to carve something too detailed and you see your brushes go straight in a direction without a stop point. lol
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-15 12:19:04 UTC Post #315722
The map I'm trying to open

Choosing a Steam installed game will crash every time I choose 'Half-Life', though cstrike and blue shift will not crash.
When choosing 'mod' without Steam Install ticked, it will snap back to cstrike every time I open game config. The Core does appear in the list and I am applying and closing every time I choose it.
User posted image
FGD setup, I have also tried just with half-life.fgd
User posted image
Archie ArchieGoodbye Moonmen
Posted 7 years ago2013-09-15 19:45:45 UTC Post #315725
Here are the files you asked:

The pack contains a 3D view clip and the .RMF I'm using.

All the testings are made with both the new OpenGL 1.0 options several times:
  • The "Light" entities issues seems almost fixed now (It fixes after re-opening the .RMF), but I can see the light's sprite disappears the more I go far from it showing me a square-sprite thing as you can see in the clip.
  • For the transparent textures issue, the texture I used in the clip is "{RAIL1B" from halflife.wad. And on the textures browser I am able to see the transparency, but not when applied. The same thing happens if I tie it to a func_wall and set it to "Solid, Texture or Additive" at 255 FX amount, no change, still white. You can see it in the clip.
  • The generic texture viewing in the 3D view seems resolved (double restart of Sledge when applied the other OGL option) as you can see in the clip. But the problem is still visible with textures that's supposed to be transparent (like Bevel, Null, Clip, Origin, etc...).
The textures I used where you see this fading-like effect are, firsly, the BEVEL from the latest version of ZHLT. And secondly, the BEVEL from the latest version of VHLT. It seems to only works properly with the original/standard pink "AAATRIGGER" texture, since I'm able to see it's correct transparency like on Source's Hammer TRIGGER texture (tested several times).
And another strange thing (not able to reproduce it, it just happened once, tried to reproduce it several times with no success) is if I replace that AAATRIGGER texture with another one (HINT for example) the thing that supposed to be a sort of alpha channel for the transparency becomes the previews applied texture (the AAATRIGGER). So if I go far from it, the fade/transparency effect is replaced by viewing the previews applied texture.
  • Decals are not visible (decal below: "{TARGET" from "decals.wad"):
User posted image
  • Opening the same .RMF with VHE results in an "Out of memory" error message (tested several times):
User posted image
  • Opening the same file but exported as a .MAP file with VHE results in this error (tested several times):
User posted image
And then: CRASH!
The program stops working and close by itself after 10-15 secs more or less, displaying a "Loading file" little window with an empty loading bar in the middle of the screen. And since the program has stopped working, I wasn't able to capture a screenshot of it (tested several times).
  • Sometimes, when the texture tab is opened, is impossible to navigate through the 3D view by moving the mouse, WASD only (pressing "Z" several times doesn't work).
  • The compiling process is way too short (even less than 1 second, so that's impossible). The log didn't stay open. No log saving in Sledge directory. I'm not able to set the compiling options, it immediately starts to compile when I click "Run" or hit "F9". Here are my "After Compiling" settings:
User posted image
Also, the final .BSP result loaded in game is not playable (fully void, no lights, no solids, no entities. You can only hear the player footsteps and basic sounds like the HEV).
  • The new Clip Tool is amazing! But sometimes it doesn't cut anything.
  • "Hide mask" option in the textures tab doesn't work (the selection stays red highlighted).
  • Textures browser filters not saving (I have to re-type the filter everytime). And the idea of selecting the wads from the browser in real time is great!
  • "Carve" tool doesn't work properly: If I carve a simple cube, it deletes the carved cube leaving there the solid I used to carve only instead to leave there both.
  • "Make hollow" "CTRL+H" shortcut doesn't work as mentioned in my previeous post, and if I use "CTRL+H" when other solids/entities are visible in the map, it deletes everything but the solid I tried to hollow, without hollowing it.
  • Almost every texture is uncorrectly visible in the 3D view (some exceptions for "GENERIC" labeled ones), mostly textures with symbols like "{, -, +A, +B, scroll" etc.... Some are white and some has that strange fade/transparency effect. To fix this, I need to restart Sledge several times until the problem is solved.
  • With the "Vertex Manipulation Tool", in the 3D view, if one corner of an edge is selected, in the other 2D views it moves the entire edge corners instead of the selected one only.
  • Entity type not showing in the below bar:
User posted image
  • I noticed that the max FPS in the editor are 64. Why? VHE's max FPS has no limit. Working with 64 FPS makes my mouse reaction/movement a bit delayed (like when V-Sync is turned on). If you can change this it'll be better. :) Or maybe add an option?
  • "Hide Null Textures" option doesn't work, they're still visible.
  • "Flip Objects" shortcuts "CTRL+L" and "CTRL+I" doesn't work.
  • The Torus Brush Type is amazing:
User posted image
  • Sometimes the "Selection Tool" doesn't work properly (somentimes doesn't select and sometimes selects a near or the nearest object or face instead of selecting the one I want to select).
  • "Used textures only" in the textures browser doesn't work.
Final words: I'm actually unable to map with Sledge unfortunately due to all the above things. I hope you can solve these issues. May my help help you help us all! :D xD

P.S.: Sorry for the long post. D:
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-16 13:02:48 UTC Post #315728
hmm... "hide Null textures" works fine for me.

-sometimes the brush-tool does not create brushes.

-"split face" in the VMT does not work properly. For example see the following pictures. If I split the face from the center to the bottom right vertex first then i can split the face a second time.
User posted image
But if I split the face from the center to the upper left vertex first, then i'm not allowed to split a second time.
User posted image
I've choosen the vertex to the upper right as an example for the second splitting. It's the same result for the 3 other directions in both cases.

-Smart edit for entities does not work for me. Can't change/add/remove entries

btw. nice editor ;)
Posted 7 years ago2013-09-16 15:26:40 UTC Post #315730
@manionsen: hmm... "hide Null textures" works fine for me.
Maybe because you're using the latest OpenGL version in the options. I'm using the 1.0 version because my pc is a crap. :P
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-17 05:41:31 UTC Post #315743
Hey, I don't want to sound like a noob, but how to get the Camera tool?

Btw, the OpenGL 1.0 version works :D
Posted 7 years ago2013-09-17 08:11:30 UTC Post #315744
Oh, yes OGL 3^^ sry

@ciba43: press z in the 3D-window
Posted 7 years ago2013-09-17 10:14:59 UTC Post #315745
@Archie: That VMF is opening without errors for me with just the Half-Life FGD, I also tried the ZHLT FGD and it was fine as well. Could you pastebin the contents of the "%AppData%/Sledge/Settings.vdf" file so I can see if the problem lies somewhere in the config? I might need a bit more info about what's crashing (how and when) when choosing different games/mods, too.

I will investigate what the mod selection in the settings window is doing (though right now that value isn't being used because proper compiling isn't implemented yet).

@Alberto: I have no idea what's going on there! :P I will add some settings to disable transparency and other things, hopefully that helps your issue (at the cost of removing transparency, of course). Hopefully this helps with all your transparency-related bugs, but I can't be 100% sure at this point.
  • The "out of memory" bug when you open the map in VHE has been identified, thankyou for reporting the issue and it will be fixed in the next version. You will need to open and re-save the RMF in the next version of Sledge, and then it will open in VHE.
  • For the "Z" key not letting you use free-look, try moving the texture application window so that it doesn't overlap with the 3D view. I will try to make a better solution for this in the future.
  • Proper compile tools are part of the plan and right now only the most basic compile features are in there. For now, it's best to use a batch compiler tool.
  • The carving and clipping errors have been reported before but I have not been able to look into these issues yet. I tried carving a basic cube like you said, and didn't notice the behaviour you described. Can you show an example?
  • Ctrl+H is the hotkey for "Hide Unselected Objects" (from Hammer 4). "Make Hollow" doesn't have a hotkey now. In a future version, hotkeys will be customisable. This is the same for the "flip objects" hotkeys.
  • In the vertex tool, hold SHIFT while clicking a vertex to only select the topmost vertex. This is written on the detail text on the VM form, under "standard mode".
  • I have fixed the status bar showing the entity type in the next version.
  • I will look into vsync options, but it's definitely not a priority for me. Having an FPS that's higher than your monitor's refresh rate makes no sense. If you have options in your video card driver settings to force vsync on or off, try using those.
  • The "Hide null textures" not working is a result of using the different renderer, I have fixed it for the next version.
  • Could you explain the issue with selection in more detail?
  • "Used textures only" not working is a known issue, it will be added later. (Edit: I just added it, it will be in the next version)
@manionsen: Can you please give me an example of a brush that the brush tool doesn't create? A screenshot of the box size, the brush type, and selected values would be very helpful!
  • I can't tell what points are selected in the "split face" screenshots because there are so many and it's confusing! Could you explain the problem in more detail please?
  • Smart edit only supports a subset of data types right now, more are going to be implemented in the future. I will make sure that I add support to add and remove properties as well!
@ciba43: Camera tool isn't implemented yet, sorry! It will be added in a later build. For now, press Z in the 3D view to go into mouselook mode and use WASD to move around.

Thanks for the feedback, everyone! :)
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-17 10:42:26 UTC Post #315746
ok, I think I tracked down the cause of the Error.

a) In Hammer you can only split faces when you select vertices of the same type (2 orange vertices // 2 white vertices), but not mixed. In Seldge you can select 1 orange vertex and 1 white vertex and split the face.

b) the "merge overlapping vertices" sometimes creates orange vertices instead of white ones which causes an invalid solid structure.


Another thing i noticed:
The brush-duplicate feature (Shift-key + mouse-dragging) makes the copied brush invalid.
Posted 7 years ago2013-09-17 10:57:41 UTC Post #315749
Thanks, I'm finished for tonight but I will work on that bug tomorrow :)

On the second problem: have you got an example of the copy creating an invalid brush? What kind of invalid? (concave, coplanar, etc?)

Got a bunch of stuff done tonight, mostly Alberto's bugs but also a few of the others too. Hopefully this weekend I will have a new build with a bunch of fixes for you all!
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-17 11:15:00 UTC Post #315750
i just created a simple Block-Brush, pressed shift and dragged it with left mouse button. So now there are 2 Block brushes. When I go to "Check for Errors" it says "invalid solid structure" and about 4 times " texture axis perpendicular face"
Posted 7 years ago2013-09-17 11:44:15 UTC Post #315751
That's....really strange. I did the exact same thing as your video, but didn't get any errors D:
Can you please upload a copy the RMF with the invalid solids? It might help me to debug the problem. Could you include a copy of the "%AppData%/Sledge/Settings.vdf" file as well? It might be related to a particular option in the settings window.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-18 01:38:18 UTC Post #315754
  • Any plan to render dimensions of selected brushes in the 2D views?
Also. Sledge crashed.
I opened a map and messed around without any loaded wads.
I closed the map with the X in the tab.
Loaded a few wads
Opened a new map,and it crashed.
  • Also Also, I'm so used to the way hammer is so don't shoot me for all these nit-picky things. While browsing for textures, if a texture is selected, pressing enter doesn't do anything. Hammer usually selects the texture and exits the browser.
I like it!
Looks sharp and plays nicely. :)
Tetsu0 Tetsu0Positive Chaos
Posted 7 years ago2013-09-19 03:58:40 UTC Post #315761
Thank you for everything! And don't worry for the transparent issues, if I have to work with non-transparent textures it'll be good anyway since VHE does the same. :D
And yup, forgot about the CTRL+H doesn't hollow a brush on VHE 4 lol, my fault. Even on the vertex tool, my fault. Sorry. ç_ç

You mean the Selection Tool issue not selecting properly? If yes, here are some examples:

Imagine those 2 as solids, entities or brush faces:
User posted image
Sometimes if I select one of these near the other (the arrow points where I click to select), the Selection Tool selects me the other one. Same thing for textures and entities (objects in the map):
User posted image
That's the issue. Which most the times this is annoying when I have to select multiple brushes, faces or entities that are near or next to each others. :

Hope you've understood. :)
Yeah, that's the only problem affecting me! ç_ç
Yeah it works, but it works to you in the same way it works to me? Or am I the only one having these issues?
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-21 02:59:53 UTC Post #315828
New Release!
This release fixes a bunch of the errors reported above, including the problem with cloning brushes and the one that caused a Sledge RMF to crash VHE. Also added is the ability to add/remove keys in the Object Properties window, options to disable various transparency features (hopefully these work, Alberto!), as well as a new window that shows the logical tree view of the current map (this is good for debugging and other low-level stuff):
User posted image
Change list:
  • Added non-smartedit editing and additional smartedit controls to the Object Properties dialog
  • Add options to disable various transparency-related features
  • Added the logical tree view
  • Fix several errors when choosing game/mod directories in the settings window
  • Pressing enter in the texture browser triggers selection for the current texture
  • Implemented "used textures only" in the texture browser. Fixes #38.
  • Implemented 'hide face mask' in the OpenGL1 renderers
  • Show entity type and targetname in the status bar
  • Made tool windows closable via the "X" in the top corner
  • Fix a bug in the RMF writer that was outputting strings greater than 250 characters long, which broke compatibility with Hammer.
  • Fix multiple issues related to culture settings in the map writing code
  • Fixed the entity editor to work for the worldspawn object
  • Run helpers before the render is initialised. Fixes #59.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-21 04:55:53 UTC Post #315831
Fantastic new update! The "Logical Tree View" is pretty nifty and I can see it being very useful for those problematic maps (usually the engine pushing ones). Any date for Sprites and Models in the 3D view? That would basically make Hammer obsolete completely for me. Also that History section, another great new feature coming soon?
Posted 7 years ago2013-09-21 05:27:08 UTC Post #315835
Yeeeeah! :D

Thanks B0$$! ;) Now I'm gonna try it! ;D
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-21 07:07:51 UTC Post #315842
Tree view has a few issues with it that I've noticed so I'm working on those in the next version. Showing models in the 3D view is a pretty complex task so I'm not sure when that will be implemented >_>

The history section will show the undo list in a visual way (basically the same as Paint.NET does it), and when it's done it should also allow undo within the VM tool.
Penguinboy PenguinboyHaha, I died again!
Posted 7 years ago2013-09-21 12:54:17 UTC Post #315844
including the problem with cloning brushes
It's not invalid anymore, but it still creates the "texture axis perpendicular to face" error for me :/ For now it does not happen every time (like it did before), but like every second or third time i clone a brush. That's very strange i think... I know this is fixable by selecting the brush and re-align the textures, but doing this nearly every time when cloning a Brush is really frustrating.

Edit: Error occurs only when "texture lock" is enabled
Posted 7 years ago2013-09-22 02:09:17 UTC Post #315853
Reporting bugs:

-I'm still having the same problems with some normal textures unfortunately :( but less than before.
-Also, transparent textures doesn't work (they're white as before) even with ALL the transparent options to disable transparency and a double restart of the program.
-"Light" entity sprite is still strange (same as the clip I sent you few days ago).
-Opening the .RMF with VHE now works, but when I go to compile it, it gives me the same error you pointed previously in the changelog: "* Fix a bug in the RMF writer that was outputting strings greater than 250 characters long, which broke compatibility with Hammer." Let's just say that you changed the error position somehow. :P
-Exporting a .MAP file with Sledge and then compiling it with Muzz's Compilator 3 doesn't work. I got the classic issue "There was a problem compiling the map" in the .log. And, of course, the .RMF is pretty simple (the one I provided you) and I'm sure it doesn't have any errors.

I hope you can solve the transparent textures and the compilation issues more than the other issues, otherwise I can't still map properly with Sledge. :(
Alberto309 Alberto309weapon_spaghetti
Posted 7 years ago2013-09-22 02:35:49 UTC Post #315856
Hey dont you have XP service pack 2 still? Why not grab 3?
Tetsu0 Tetsu0Positive Chaos
Posted 7 years ago2013-09-22 09:14:44 UTC Post #315860
The question could be: "Hey don't you have an USB Stick? Why not be fucked?" :D Can't. :P I installed XP with SP2 integrated with the original CD after my internet was disappeared. So yeah, no SP3. :3

And I think there's not that much difference to make Sledge work on my pc with SP3. But sure I'll try asap to upgrade it as soon as my connection returns. ;) Thanks for the interest, Tet. :)
Alberto309 Alberto309weapon_spaghetti
You must be logged in to post a response.